Error: GPGME error: No data - new

Well i would not have known what the problem actually was other than it’s not able to download the proper files which always leads me to think it’s a mirror problem. Changing the pacman.conf will do that. :thinking:

1 Like

Originally the EndeavourOS repo was correctly set up and active.

@murugesan
Do you have the EndeavourOS repo active now?

My guess would be they commented it out on their own (on purpose), but missed the first line or did not realize it was part of it.

1 Like

I assume that too. Just asked if the EndeavourOS repo is working on not, as others seem to work.

Accidentally happened while following the suggestions from this forum. As mentioned in the beginning.

1 Like

No.

“No” meaning it is currently still NOT working?

Or “No” meaning it wasn’t working, but it is now?

If it’s still not working, run the command below, copy the text and paste it in the thread.

xed /etc/pacman.d/endeavouros-mirrorlist

Maybe they don’t have xed. :wink:

Well, they do

I asked them to use a GUI app because they were posting the text on the thread inefficiently.
:wink:

1 Like

They were having an issue before attempting doing this, so don’t blame me.

:sweat_smile:

Sorry for the late reply.

It is working now.

started working only after commenting [endeavouros] in pacman.conf.

xed /etc/pacman.conf

#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg     = pacman glibc dracut kernel-install-for-dracut eos-dracut
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
Color
ILoveCandy
#NoProgressBar
#CheckSpace
VerbosePkgLists
ParallelDownloads = 5

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

# [endeavouros]
# SigLevel = PackageRequired
# Include = /etc/pacman.d/endeavouros-mirrorlist

#[core-testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

#[extra-testing]
#Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

Still confused. More confused?

For the lines above in /etc/pacman.conf, it should look like below. No hashtags. If it is exactly, like below, then you may need to refresh the keys.

Now I removed hashtags except for SigLevel = PackageRequired.

Because
SigLevel = PackageRequired

line only gives error: GPME error: No data.

It should either be like this

[endeavouros]
SigLevel = PackageRequired
Include = /etc/pacman.d/endeavouros-mirrorlist

or like this

#[endeavouros]
#SigLevel = PackageRequired
#Include = /etc/pacman.d/endeavouros-mirrorlist

Otherwise, you may have errors.

So, either add hashtags to all the lines related to the EndeavourOS repo, if you don’t want to use it. Or remove all the hashtags to avoid errors.

2 Likes

Maybe you have corrupted EndeavourOS packages or signatures in /var/cache/pacman/pkg. Try removing them and update again.

2 Likes