Eos-update-notifier not showing any updates

In my new PC i install plasma using the latest ISO. But the eos-update-notifier is not show any updates.

1 Like

Is this a brand new installation just now? When you install online, it downloads the latest packages and installs them. So you won’t have updates just after installation.
Wait a day or two and you’ll get updates.

Its yesterdays install. And if i run pacman -Syu it shows 9 updates

Do you mean it doesn’t show updates automatically?

You can run eos-update-notifier on the command line as well, and if there are updates, it should show them.
You could also use checkupdates on the command line to see if there are any updates.

EDIT: I can see there’s a problem in eos-update-notifier. Thanks for the report, I’ll check what happens.

Not sure what the default value is set to, but my eoe-update-notifier goes off once a day at midnight if any updates are available. Any updates that come after that are on me to find out via the yay command since it only generates a notifications once every 24 hours. You can chance this value to something different if you like.

Yes it doesn’t show updates automatically. with the " eos-update-notifier shows nothing

my settings are fine. Its not showing updates after reboot

You haven’t adjusted any eos-update-notifier values or have you?
If I’m to understand the issue correctly, notifications aren’t being displayed?

One of the goals for the application is to periodically check for updates at a set time specified by the user. Under the “Schedule” tab, I have mine set for 30sec at startup, check period set to daily (aka every 24hrs it’ll run once), and checked the box for Persistent.

I’m not sure if you are wanting eos-update-notifier to notify you the second updates are release perhaps.

Edit: Also, one thing I’d recommend you try is to use the Reflector Simple application (should be installed by default, if not it’s in the EndeavourOS repos), and you want to run that to make sure your mirrors are up to date. For that just select your country, set max number of mirrors to something like 10, click OK, wait and let it run, then it’ll ask you to save it and click okay and maybe try seeing if you still have updates showing then.

i done all that, I have set for 30sec at startup, check period set to daily (aka every 24hrs it’ll run once), and checked the box for Persistent.

Found the problem with a recent previous change, and fixed it.
The new version is 1.13.14-1, and it is coming soon to the mirrors.

Thanks again for the report! :+1:

4 Likes

Do we thank the guy that fixed what he broke? :stuck_out_tongue:
Just kidding, glad to hear it was a fixable endeavour :wink:

2 Likes

It was a silly omission from my part, sorry about that. Some return values were incorrectly interpreted.
Fortunately it was very easy to fix.

Well, this way I can create more work for myself…
Wait! I get no salary… :wink:

4 Likes

Strange… i never have any issue with it on ALL my desktops. It just always worked.

Either that, or you didn’t notice when it hid from its responsibilities! I didn’t! Of course, I have alternate means of knowing when and what updates arrive with my conky display, or my bash function display of all updates pending - so the notifier gets mostly ignored if it DOES come up. I really should disable it, I guess, rather than ignore it!

Always displayed

Currently awaiting updates:

Name                 Current    ->  New        DownloadSize
----                 -------    --  ---        ------------
eos-hooks            1.4.14-1   ->  1.4.15-1   16.05 KiB
eos-update-notifier  1.13.13-1  ->  1.13.14-1  24.84 KiB
libxcrypt            4.4.25-1   ->  4.4.26-1   88.56 KiB
welcome              3.16-4     ->  3.16.1-1   30.88 KiB
 
AUR Packages
------------
Name          Current                 ->  New
ckb-next-git  1:0.4.4.r1.g50ee67dd-1  ->  1:0.4.4.r100.gdc4dc54c-2

Currently awaiting update counts:

4 + 1 new | 0 ignored

Trust me i noticed. It’s been working the whole time. :man_shrugging: