EOS Update Notifier Everyday said. internet Connection is not

Hi, Sorry for strange English. And Hi. I glad use EndeavourOS.
Because This OS, I can stoping Distro hopping. So Thank you.
However, EndeavourOS Update Notifier everyday said. Popup info.

Internet connection is not available!

Yes i no use everyday internet connection. Because that is quiet. But why said everyday?
I changed EOSUN check to month. not day. So i not Linux expert. I want not daily update.
But… This popup everyday popup info. Everyday, Login, Start, Anyway.
How stop this? I want not see this popup info. Just is, Sorry obstacle.
I did update EndeavourOS is 01/11. So next update 01/12 maybe.

You can post in your native language in one of the #endeavouros-united sub-categories.

If you can find out what the popup notification is then you can disable it. You will have to look at your startup applications to find that out.

1 Like

@Panerz
Welcome! :partying_face:
You can also use some translator, for example https://www.deepl.com/translator


I think he means default EndeavourOS update-checker

4 Likes

The Welcome app also expects to find the internet available - and (eventually) will ‘complain’ if it isn’t found. Perhaps tell it to go away?
(along with instructions on how to re-activate when needed)

2 Likes

Welcome! :smile:

eos-update-notifier can be configured to update e.g. weekly or monthly with terminal command:

  eos-update-notifier --conf

But as said, Welcome also checks for internet connection.

Currently there isn’t such a configuration for Welcome, but you can disable Welcome by clicking button Don’t show me anymore.
To use Welcome again, simply click the Welcome icon.

5 Likes

Thanks for teach categories. Maybe, Nothing or little Language. So Japanese.
And I means that software is @keybreak is right. EOS Update checker? Sorry mistake name.

2 Likes

Hi! Thanks welcome call. I glad.
And i not know deepl. Thanks, I use google translate. But I try use that translator. That simple and look easy.
Sorry, Even If I use translator, Maybe, I talk English is Strange anyway. That Default for I only. I want study German and English.
Yes I means is EOS Update Cheker. Thanks.

1 Like

Hi, Yes EOSUN is everyday say complain on startup… Where That option. I search but no found.

Hi! Thanks Welcome call! I think that call is surprise. I glad.
Yes I set that check and change to monthly, But no fix.
Maybe you means Welcome Application? I checked That(Sorry! Please no cry!), But EOSUN is maybe other task.

Google translate:

こんにちは!ありがとうウェルカムコール!電話は驚きだと思います。よかったです。 はい、そのチェックを毎月に設定しましたが、修正はありません。 多分あなたはウェルカムアプリケーションを意味しますか?確認しましたが(ごめんなさい!泣いてはいけません!)、EOSUNは別の仕事かもしれません。

Kon’nichiwa! Arigatō u~erukamukōru! Denwa wa odorokida to omoimasu. Yokattadesu. Hai, sono chekku o maitsuki ni settei shimashitaga, shūsei wa arimasen. Tabun anata wa u~erukamuapurikēshon o imi shimasu ka? Kakunin shimashitaga (gomen’nasai! Naite wa ikemasen!), EOSUN wa betsu no shigoto kamo shiremasen.

2 Likes

@Panerz
Hi :wave: I speak english. Right now learning Japanese. :japan: :hugs:

I can only say ‘konnichiwa’ right now. Kanji is difficult for me, but I will try to learn.

I find every language strange. Only C++ and Python are good for me. :grin:

When you click ‘Don’t show me anymore’, it will be disabled and not show again. :+1:

4 Likes

Hi, Well. Google Translate is OK, Mostly.
Maybe. I speak English is More Strange than of Google Translate Text. :cat:

1 Like

Hi! Konnichiwa! :cat: Thanks gently call. I glad.
You Leaning Japanese? If you want help for leaning Japanese, Maybe little i can assist.
Kanji? Yea, it’s difficult. That is Many Many many line. Example > Difficult = 難しい
But C++ is more difficult for me. And python. But I leaning Python. That is powerful. You can python writing? That Wonderful. :tada: I can’t.
And your right, Every language all mystery. :jack_o_lantern:

Thanks Screenshot! Maybe That is not fix this issue, I paste Screenshot.

1 Like

Sorry I do not know how to fix the issue. I cannot recognise the screenshot. :sweat_smile:

Probably @Elloquin or @jonathon will be able to help.

1 Like

Ok:cat: and Sorry. I try ask for @Elloquin or @jonathon. But thanks!

1 Like

Hi. So you know that? yad is what?

Hi, And you know this yad? I want stop everyday this popup dialog.

yad - Yet Another Dialog

Essentially it is a way of adding GUI functionality to a bash script - and is surprisingly capable. A numberof things will stop working without, though - so you have to decide if you really want it gone :grin:

Among the casualties if you remove yad will be EOS Notifier, Welcome, and reflector-simple.

From what I have seen on this thread, what you need is a delay in the startup - so your connection is in place before ‘everybody’ starts checking it. There are many ways to achieve this - but I’ll leave it to others to suggest the ‘best’ way…

2 Likes

@Panerz

Don’t remove ‘yad’. It not the problem.
You may want to remove eos-update-notifier. It will mean you don’t get update notifications.
Run in terminal:

yay -Rns eos-update-notifier

I’m a relative newbie, and others probably will be aware of better ways.

1 Like

Thanks for telling me about Yad! :parrot:
I not uninstall for Yad… It was a close call. :jack_o_lantern:
Yes, the problem is that they ignore the update interval set by EOSUN and complain about the lack of internet connection.
If you set up monthly, then you should complain only when you check for update.

1 Like