EOS update from today 4th May screwed Chrome website display

Hi, I just installed the upday from May the 4th. After a reboot Google Chrome now has problems to display some webpages like GMail, O365, even this forum page does not display fonts.

Firefox works just fine.
Chrome Version 113.0.5672.63 (Offizieller Build) (64-Bit) - updated yesterday and worked until this morning.

Some comparisions between Chrome/Firefox for same page:

Any ideas?


EOS update from today 4th May

It’s difficult to say what packages got updated on your system and which of them may have caused this issue.

There are no two identical updates on two different systems depending on what packages are already installed on them.

If you are using: https://aur.archlinux.org/packages/google-chrome, have you tried to rebuild it?

Also, have you tried Chromium or other Chromium-based browsers (Brave, Vivaldi) to see if you have still the issue?

For what is worth, I just tried Chromium and logged into a Gmail account. Things look normally on my side.

$ chromium --version
Chromium 113.0.5672.63 Arch Linux

Hi pebcak. I just update my test VM to compare results. After that I’ll try on my second physical machine to see if a chrome based browser works. I’ll report.

1 Like

Hi everyone. I have the same issue. I ran chrome inside the terminal and got this error message:

link failed but did not provide an info log
[13546:13546:0504/081718.787391:ERROR:shared_context_state.cc(77)] Skia shader compilation error
[aw@aw-nb ~]$ google-chrome-stable --version
Google Chrome 113.0.5672.63 
[aw@aw-nb ~]$ chromium --version
Chromium 113.0.5672.63 Arch Linux

I have reinstalled google-chrome which didn’t help. I also have this issue with chromium.
Maybe it helps.

Additional info: I could downgrade chromium to version 112 via pacman -U. Here chromium works as excpected. So I guess somethings broken with the chromium related packages.

1 Like

I in between updated my second (spare) laptop. Chrome works here as expected. Same inside a VM.

Chrome started from Konsole on first problematic laptop as well gives me the error @DerAlex posted:

link failed but did not provide an info log
[19903:19903:0504/083359.111876:ERROR:shared_context_state.cc(77)] Skia shader compilation error
1 Like

According to the AUR comments, it is related to Wayland. So maybe force XWayland for the time being.

1 Like

I’m running on X11, but tried Wayland once to test. Same error.

(Using Plasma / KDE )

1 Like

Same for me. I am using Gnome under x-org

I confirm that updating Chromium with the 4 May’s package breaks the display rendering

edit: I also confirm that downgrading (archive for Chromium) solves any display problem.

1 Like

Just tried the google-chrome-dev package. It works. Of course a new .config/google-chrome-unstable is being created.

I then tried google-chrome-dev with a copy of my stable .config dir to the unstable one to have all my settings back. This works, too. Only fonts on tabs, menu, bookmarks are pretty small.

So I conclude it’s not the settings/config, but this chrome version in combination with an update today (I saw webkitgtk2 in the list along with a python update that broke the fprintd on my thinkpad x270…)

I hope a quick update to chrome will fix this.

I have not experienced these phenomena that you wrote about. Maybe you should try disabling the extensions and see if the problem persists, then re-enabling them one at a time. By the way, Google Chrome Dev works flawlessly, but maybe the Beta as well, I haven’t tried the latter, only the former. If nothing helps, then you should wait for the next stable version.
These are usually the general methods for such cases. Of course, you can try many other things, because your machine may have special conditions that only you can see. For example, I used to have to turn off hardware acceleration with Opera, because the browser simply froze when loading some web pages. Meanwhile, I see that you also wrote this.

I found a solution. Or Workaround?!?

As my main laptop has an AMD Ryzen and the other is an old Intel I thought about usage of GPU.

I disabled “Hardware acceleration” in Chrome Settings, restarted Chrome and it works again!

1 Like

Kind of difficult to disable it :smiley:

1 Like

Try Ctrl-Shift-I to enable developer tools or Ctrl-- or Ctrl-+ to change display size. That brought back the display temporarily in some cases

Try passing --disable-gpu --disable-accelerated-video-encode to the command line launching Chrome.

This should disable all hardware acceleration.
Go to chrome://gpu/ to check.


Bare metal and wayland - not seeing this on Chrome or Chromium with:

google-chrome-stable --enable-features=UseOzonePlatform --ozone-platform=wayland

Gmail and forum tested - All OK.

Chromium - Version 113.0.5672.63 (Official Build) Arch Linux (64-bit)
Chrome - Version 113.0.5672.63 (Official Build) (64-bit)

echo --disable-gpu-driver-bug-workarounds >> ~/.config/chrome-flags.conf

this fixed it for me, and it seems the hw acceleration is still enabled.

1 Like

Did you verify that in chrome://gpu?

If it is still enabled, then perhaps no need to disable them completely. Just working around the bug is enough then…

Interestingly, I didn’t have this isuue with Chromium after this update. Also updated my packages to Testing to get the GNOME 44.1. Still good.

I don’t have this problem on KDE either with Chromium. Hardware acceleration is on and using X11. I don’t use the Chrome version.

Same for me (protonmail).

I installed a different browser (LibreWolf).

Update :
$ chromium --disable-gpu
works fine.

Update 2: chrome://gpu/
chromium_GPU_Internals.pdf (221.3 KB)

1 Like