EOS Solutions and Problems after hopping from MX Linux

Instead of a random github post from 2018, I think this link would be more appropriate: https://wiki.archlinux.org/title/Mkinitcpio#Possibly_missing_firmware_for_module_XXXX

2 Likes

problem 2
i have been developing some web apps for some years now with fatfree php
with MX Linux, i spawn some vhosts locally to mirror the real ones on the vultr box.
with EOS, i did not have the ensite convenient script and have to do little more conf changes to get it working.
the main problem was i got the latest php 8 as the default php which is not compatible with the latest fatfree php at this time.
this opened up a can of worms and had to fight lot of bugs in the existing project. in the end i have to downgrade to php7. the problem with this is i have substitute php7 with php in many places of conf.
also had to make a soft link php7 as /usr/bin/php.
this is a maintenance night mare now, going forward in future.
also if i try to install composer the defacto package manager of PHP, it pulls PHP8. seems i may need a little more effort to make both php8 and 7 co-exists.
php8 for composer dependency and php7 for actual day to day work.

luckily i did that based on the link. sorry for trying to be oversmart and correct you.

Running old versions of software like php on Arch-based distros is a nightmare.

I would spin up some kind of container(docker/podman/etc) and run your php stack in there. It will be a lot easier in the long run. There probably are already docker containers made for that purpose that you can just install.

2 Likes

good idea. i have never explored docker till now. this can be great reason to start.

Solution 2
I never had the guts to try window manager instead of full fledged desktop. On MX Linux it was in the beginning XFCE and then to KDE for the MacOs Looks. Though, this is not specific to MX Linux and any KDE could be made to look like that.
After moving to EOS, there was big shift in paradigm. I wanted to avoid distraction and be more productive as a programmer.
Got Qtile working on the first attempt but have to install Gnome because after an update, I was unable to login. Now, Gnome, Qtile WM and Worm WM co-exist.
I also have Qtile, Xonsh and Kitty with python as the common denominator for all three, my daily driver
I could not have dreamed of such thing MX Linux. May be it is possible with MX, but somehow the environment did not provide me with the necessary courage for the endeavor :slight_smile:

You could also try vagrant, its purpose is the configuration and management of virtual development servers.

https://wiki.archlinux.org/title/Vagrant

Big benefit of vagrant is the ability to define and configure development VMs declaratively in vagrant files, very powerful once you get the hang of it.

2 Likes

thanks @otherbarry
i prefer simplicity over sophistication when it comes to this. i am never going to push the entire website with Apache to cloud at once. instead i may have a maximum of 10 small websites, all of which are dependent on the same Apache server running locally. Dont know if i am making sense here, but to give an idea at the outset i am more attracted to podman even with my limited experience in containers.

EDIT: i solved one of the PHP problem by installing composer globally.

problem 3: redshift
my location does not get picked up automatically because there is no way redshift could find out what my location is. since i am using a desktop this is not required at tall. i spent sometime to find out. though many things i mentioned here are wrong, i am right about the location. once the location is fed manually, redshift does not have any problem in showing up as an icon on the Qtile topbar. i then i just need to add it to the shell script that qtile runs during startup, though i did this just now before posting this.
screenshot

Solution 3: AUR packages autocomplete
This one was working since i installed Qtile and one of the xonfigs i guess. I become conscious only when i tried to do this

Check out yourself on how cool this one is.

Solution 4: Searching and watching youtube videos like a playlist

$ yay -Syu ytfzf

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                     [-----] 100%
(1/1) checking package integrity                   [-----] 100%
(1/1) loading package files                        [-----] 100%
(1/1) checking for file conflicts                  [-----] 100%
:: Processing package changes...
(1/1) installing ytfzf                             [-----] 100%
Optional dependencies for ytfzf
    dmenu: use dmenu for search prompts and results [installed]
    rofi: use rofi for search prompts and results [installed]
    fzf: use fzf for results
    ueberzug: thumbnails image preview [installed]
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...

Installed but not getting thumbnails yet. Will figure it out sooner or later.

I too have lowercase: us. And I too don’t remember adding it myself.

But I came across /var/log/endeavour-install.log and it had this:

14:48:16 [6]: void Config::guessLocaleKeyboardLayout()
    Got locale language "en_IN"
    ..  special case language "en_IN" becomes "us"
    ..  looking for locale part "us"
    ..  matched "us"
14:48:28 [6]: QML Component (default slideshow) Next slide

And a little later:
.. Written KEYMAP= "us" to vconsole.conf 0
My /etc/vconsole.conf has

KEYMAP=us
FONT=ter-122n

(I installed terminus-font thanks to ermanno’s Arch videos.)

1 Like

Every web developer should learn how to use vagrant.

Once you learn it is simple to use.

Create a vagrant file, declare the config, and vagrant will build the virtual server for you. It is a huge time saver.

thanks. @otherbarry will check it out.
for now, bypassed composer in AUR.
whenever PHP tries to update itself to 8, there will be a complain that /usr/bin/php already exists and i will be made aware of the conflict.
will live like that. let us see.

Problem 4 Adblock and VPN
MX Linux comes with adblocker package though i still got advt when watching youtube videos.
Someone suggested to have an adblocker at system level instead of browser level for obvious benefits.

Secondly, my country blocks some movie sites and xsites, so i want to use a VPN with the ability to select country for speedy VPN’ed page.

@dalto and others any suggestions for adblocking and VPN both mainly geared towards browser, please.

You could use mpv or celluloid to stream youtube videos without ads.
If you want to have an application, there is Freetube.

2 Likes

A few things:

  • For VPN recommendations, take a look at this topic where those are discussed in detail.
  • The most common way of doing system-wide adblocking is via a DNS blacklist. There are a few ways to achieve this:
    • The easiest way is to just change your DNS servers to public adblocking DNS servers. The downside of this option is the lack of control.
    • Implement your own DNS blocking using a list
    • Use something like pihole
  • In my opinion, DNS adblocking should supplement your browser adblocking, not replace it. Browser adblocking is more effective because the rules can match the entire URL instead of just the domain portion. By using both, you let your browser do the heavy lifting and the DNS blocking protects the rest of your traffic.
3 Likes

I personally use Vivaldi with its own inbuilt adblocker and uBlock addon with all the filters on. I get 0 ads on YT and any other site. Also, there’s very little trouble with sites I visit if there’s an issue I just disable one blocker to see which one is causing the issue (mostly it’s the inbuilt one). Don’t know much about VPN’s on Linux because I don’t trust VPNs anymore.

2 Likes

Yeah, I have been using a browser-based adblocker for many years and there was a period in time when I didn’t even realize that youtube videos had ads. :rofl:

4 Likes

Still the same for me. I never get ads even on not so reputable sites. I sometimes wonder why I’m seeing the video I want when I use other computers then I remember no adblocking.