EOS not starting after update

Hello im new to EOS after using Manjaro for a couple of months as my first Linux distro.

I did a whole batch of updates yesterday before going to bed and today the system wont start anymore.

I get stuck in the [ok] screen either at “Reached target Graphical Interface” or “Starting Accounts Service”

Using Intel 8700k cpu and Nvidia RTX 2070super GPU

DE is Xfce.

Any suggestions? Is it the GPU driver?

i tried getting to start it with sddm instead of lightdm, which didnt do the trick.

So i tried startx and it returns the errors:

-no screens found
-he log file at “/var/log/Xorg.0.log” for additional information
-Servernterminated with error (1). Closing log file

Maybe it failed updating the kernel properly? You could chroot in a live iso and see if you can run an update again.

i think something with the xorg.conf broke. Arch wiki says there is a possible fuckup by Xserver and nvidia driver when updating kernel, and it really seems like it.

I just saved me the hassle, saved my data via another distro on the other drive and reinstalled EOS…

Ha, fair enough. Was it related to the nouveau driver issues?

yep i think so.