Endevouros grub not detecting other operating systems on different hard drives

I’ve seen similar issues on forum, however I do not think that applies to my case, neither those suggestions helped.

I have this layout of hard drives on my computer:

nvme hard drive - primary hard drive, with windows 10 on it, and this is my selected boot loader(grub install) drive

sda - disk with installed Ubuntu on it

sdb - storage drive, no systems on it

sdc - installed endevour os on it

During installation I selected first nvme drive to be boot loader location. However once system is installed neither of other os appear in it, neither windows 10, neither the other Ubuntu linux system.

I’ve tried updating grub with os prober on and off, tried with installing grub tools, update-grub nothing helps.

What bothers me even more is that when I install ubuntu based distro grub picks up all already installed systems in it and add new one on top of that.

How can I fix this?

Welcome to the forum :tada::tada:.

Grub no longer checks for other installed OS by default. Install os-probe

sudo pacman -S os-probe

You then need to edit /etc/default/grub to add or uncomment GRUB_DISABLE_OS_PROBER=false

Then re-make the grub config.

sudo grub-mkconfig -o /boot/grub/grub.cfg
2 Likes

Welcome to the forum!

This part does not make sense to me. I think you are referring to efi entries when you try to select another boot media like usb for installing your new distro. These multiple entries should not appear in your grub bootloader at each start unless you installed/uninstalled packages and changed config files without knowing what you are doing.

It is easy easy to fix if its just in your efi entries. If not, efi, then I suggest to start from scratch and let us know step by step what you did so we can help troubleshoot the problem.

But first:

  1. try @kjw suggestion above, 2) We need better system information, most importantly your partition scheme:
  1. did you backup your important files? Before doing anymore system changes…

Neither of the installed systems are installed in EFI mode. Everything is installed in legacy.

this should give error on output of running sudo grub-mkconfig -o /boot/grub/grub.cfg what would show what went wrong…

1 Like