Hello everyone, I am new here!

I installed EndeavourOS about a couple of months ago in a windows10 laptop. Everything was fine until yesterday, when I did some updates. Today I turned it on and the system cant boot.

More specifically: When I turn on my laptop I don’t have the option to boot the EndeavourOS, but only to reboot into firmware interface.

I don’t want to delete everything in my SSD and install the EndeavourOS again. I have important files that I need. Is there anything I can do to fix this problem? Or at least, is there any way to save my files in a USB and delete everything later?

( I used an ISO usb to copy my files from my SSD to another usb and I cant have access to them. Propably because I have password. )

hey welcome at the forum and sry to see you having such issue…
If you still have the install media at hand (usb ISO stick) you can boot to live session and repair the boot… Indeed only in cas eit is related to the bootloader and not simply settings in Bios are reset and do not boot anymore because system is set to lehgacy boot or something…
From live session you can arch-chroot:
and fix almost ever yissue related to the OS itself…

And indeed you can use the session to mount harddrive and backup files… in case its encrypted you will need to open container with your passphrase… but ISO live session is there to help with all of this.


First of all, I did chroot successfully.

Probably there is a problem with GRUB. I tried to repair it with the command:

grub-install --target=i386-pc /dev/sda2

and nothing happened (in /dev/sda2 is installed the OS). It appeared the following message:

bash: grub-install: command not found

Also I tried to transfer all my files in a usb stick and I cant find it in the terminal

You are probably using systemd-boot, not grub.

Try using arch-chroot to access your system(ensure your EFI partition is mounted inside the chroot at /efi then run reinstall-kernels


I dont know how to reinstall kernels.
Is there any tutorial to help me?

And how can I figure out if I installed the OS in UEFI mode? I dont remember.

Or is there any way to transfer all my files in a usb?

You literally type reinstall-kernels once you are chrooted into your install.


Thank you so much for your help!
It was much easier than I expected.

All I did is to boot the Live session (usb ISO), I connected to wifi network (I am not sure if this is necessary), I did chroot, and I ran the command # reinstall-kernels.

Here is a tutorial on how to chroot, for anyone who reads this, and has the same problem:

dalto and joekamprad, thank you for your attention and wish you the best!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.