EndeavourOS Upgrade “endeavouros.db” from ca.gate.endeavouros.com

When updating the system I get this error:
error: could not get the file “endeavouros.db” from ca.gate.endeavouros.com: Connection timeout after 10000 ms

1 Like

That mirror seems to be down. Run eos-rankmirrors or just comment out that mirror from your EOS mirrorlist in /etc/pacman.d

10 Likes

thanks, I just solved it

1 Like

I got the same problem but rank mirrors didn’t work. I also tried from the welcome app and it just gave error messages

[gnome@gnome-notebook ~]$ eos-rankmirrors
Fetching https://gitlab.com/endeavouros-filemirror/PKGBUILDS/-/raw/master/endeavouros-mirrorlist/endeavouros-mirrorlist
Ranking EndeavourOS mirrors, please wait …
====> Fail: no response: mirror https://ca.gate.endeavouros.com/endeavouros/repo/$repo/$arch, url https://ca.gate.endeavouros.com/endeavouros/repo/state,
==> Creating /home/gnome/.config/curl-exit-code-to-string/curl-code-to-string-converter
====> Error code 28: ‘Operation timeout. The specified time-out period was reached according to the conditions.’

Edit: Nevermind, it worked. I went back to my terminal and a bunch of new lines about ranking mirrors were there, so it seems to have done something. I’ll see if my updates work properly now… Yes it worked fine. If anyone has a similar issue, wait for a while if you get error messages when you rank the mirrors

2 Likes

Welcome @Alejandro to the :enos: forum.
Glad to see you got a solution so fast.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.