EndeavourOS or Archlinux - Installation Failing

Hello, mates.


Me and my stupid inventions!


I had until yesterday my system running well, however, with no reasonable reasons, I had the brilliant idea of reinstalling it by scratch and from there a waterfall of problem has happening.


Here are the list of problems:

  1. EndeavourOS - Calamares - Installation online cannot fetch packages.
  2. EndeavourOS - Display Resolution only in 800x600 - Offline Installation.
  3. Anarchy Installer - LightDM Display Manager stops boot.
  4. Anarchy Installer - tty does not accepts my pasword.
  5. Artix - Installation succeeded - update and packages installation fail.
  6. I have tried install EndeavourOS or Arch Linux many times and the same result.

Only debian-based distros installation succeed and work well. Right now I am using Linux Mint.


Someone has any idea how to solve this problem?

I think that @Kaan 's problem is similar to mine.

Sounds like network issues.

Also, verify your image checksums.

Also, provide some details about a specific attempt to provide people who might want to help with something to go on.

1 Like

I was thinking the same thing. Big question: wired or wireless? If wireless, is it a Broadcom adapter?

For some reason, I can never get my systems to work with the ‘wl’ driver on the installer disk. I usually end up copying in the firmware and using b43 for the install. Everything works fine, however, when I boot the installed system.

1 Like

It sounds like mirror, network problem. I install EndeavourOS a lot and i just don’t have or see these issues but i have very good internet. It’s very fast and very reliable. Whether I’m on wireless or wired doesn’t matter other than my wireless is a lot slower than my wired connection.

Edit: Make sure the mirrors are updated before you attempt an install as you want the best mirror ranking and speed.

With offline installation it should work without internet connection, right? But it didn’t …

can you add inxi under linuxmint
and report

inxi -Fza
sudo parted -l
test -d /sys/firmware/efi && echo efi || echo bios
sudo efibootmgr -v

Good Morning, my friends!


@jonathon - No problem in network cuz when I’m running the Live, everything is ok, no problem. The problem starts only on installation.


@jruschme - Wired. As I said to our friend @jonathon, there’s no problem in connexion.


@ricklinux - Mirrors? I dont think so.


@Balder - Right :wink:


How could I install MX Linux and Linux Mint flawlessly if it was network problem?
I tried EndeavourOS, Archlinux, Artix, Cam-Arch Installer and all these ran the Live flawlessly and all of them, except Artix, failed on installation.


Artix does not fail to install, but it presents a pesky problem on installing packages and updating.


Linux based on Debian that I tried succeeded on installation and ran flawlessly. So no network problem, right?


Then I read @Kaan 's post: Can’t boot in to the system after kernel 5.12.1 and Eos update and realized that his problems was similar to mine. And I remembered that Manjaro does not update the kernel like Archlinux and tried it et voilà. I’m running Manjaro with no problem.


Mates, I’m no computer or even Linux technician, but I think that the problem resides on the new packages (kernel, eos or whatever), I dont know. But it seems not to be my computer or my network.


Thank you very much.

so you can report

inxi -Fza
sudo parted -l
test -d /sys/firmware/efi && echo efi || echo bios
sudo efibootmgr -v
1 Like

What hardware? inxi -Nxxxz would be useful.

Not necessarily. You would verify that it was a network configuration issue by trying to access websites or servers directly (e.g. ping -c3 www.google.com and ping -c3 8.8.8.8).

So have you tried a kernel other than 5.12? linux-lts is in the repo, you can install that?

They are different operating systems with different software versions and different installation processes.

This said, if Mint “just works” then maybe you should use that instead?

2 Likes

Hello, my Dear Friend @jonathon
I hope you are fine!




No, mate. I haven’t and I did not try to install linux-lts.


As I said before, I’m not a technician, I’m just a noob who needs help. And sometimes I talk nonsenselessness, of course.


Network Problem - Yes, I’m having that problem, but I just found out today, when I opened Firefox and this page was opened:


My router is restarting constantely.


Boy, I’m still trying to digest this sort of disrespect. I’d like to insult you, but I won’t. But, PLEASE, ignore my post from now on, ok.

Just to note, showing the results from within a working operating system doesn’t help diagnose issues with a non-working operating system.

The question I asked would normally prompt people to try it, rather than simply say “no”.

Oh no, please do. Take what I said about using an operating system that works for you without issue or effort and turn it into an insult. :roll_eyes:

If I do that then I wouldn’t be able to suggest making sure that the r8169 driver was active.

7 Likes