EndeavourOS on a slow machine, how to fix it?

hello dear friends.

i am fairly new to endeavour: and i like it. But i guess that i have installed it on the wrong machine - or in a wrong manner - that is - with KDE and not with a damned small desktop.Version

full story: i run it on a old notebook

it is a Asus A 54L; CPU i3; 4GB RAM - note the i3 is probably a older generation. The notebook itself is about 8 to ten years old

I have installed EndeavourOS - and i have to tell you: i love it from the bottom of my heart.The first installation - was to play around and to test it - so i installed it on a quite very old Notebook.

i took the KDE-Enviroment -

after 4 Week testing and playing i have to tell you.

it collapses quite alot - i get freeze and other things - eg. in the browser (vivaldi) or the libreoffice that ia
running in parallel to GIMP and a Vivaild - juzst quits working

I get responses like so;:
ther is no -"answering " of this software - . -Do you want to close it?

Well what could i do now - are there other desktop environents !?

regards

https://wiki.archlinux.org/title/Desktop

1 Like

Disable file indexing from System Settings if you haven’t already done so.

2 Likes

Yes there are many. You can select another DE if you use the online installer. There also windows manager like i3wm that use the least RAM out of the box, but its not going to change much RAM usage of Firefox and other apps. Definitely less bloat than kde though :wink:

Edit: (and gnome)

1 Like

hello you both

many thanks for the quick reply. I am happy. MrVictory - what do you mean by disabling the indexing form Syst-.Settings!?

@pebcak - well sure thing youre right - i will try to provide you with extra infos - but imagine: if the whole system freezes i cannot even open the log files

all that things are not able

BTW: does it matter - how many tabs in Vivaldi are open?!
in other words - if i have 1 tab open or 40 - does this make any difference!?

love to hear from you

Try opening htop or btop and check your RAM usage with one or 10 tabs open.

KDE ships with an application called System Settings. Just search for it like how you would do for any other app. Then inside settings, look for File Indexing. Disable it.

if i have 1 tab open or 40 - does this make any difference!?

Yes. Some browsers like MS Edge have a feature that puts tabs to “sleep” so it doesn’t take your system resources.

1 Like

hi thanks for the quick reply - i will have a look at the terminal
here - by the way - we have the following

btw: i do not have the option to run htop or btop… the commands are not found

When I run i3wm it uses something like 300-400 Mb RAM, just opening Firefox boosts that up to 800 Mb or similar. The more tabs the more RAM.

I don’t use MS edge or Vivaldi couldn’t say, too proprietary for my taste.

1 Like

I have an i3 1.9Ghz and needed 8Gb to get a reasonable experience on KDE.

I switched to Gnome. Now I doubt the RAM was even necessary. The laptop flies and no crashing like I had with KDE Plasma.

There are much lighter DE’s like Lxqt and Lxde, but Gnome works for me, even the latest Gnome 42.

Still I will wait to see the logs.

1 Like

i want to provide more logs - btw-. what do i have to do to run the commands
with output htop and btop

I think it’s installed default on eos xfce. However, you can easily install

sudo pacman -S htop

https://man.archlinux.org/man/htop.1.en

1 Like

hi there - looks somewhat strange

image

Are you using another terminal or other instance of the package manager at the same time? It’s locking the database to avoid overwriting it I assume.

Btw nothing to do with htop itself. First fix that issue, then update your database, then install software.

1 Like

hi - well here the output - when 28 Vivaldi tabs are open

and now i close all - so that i only have one tab left

just wait a moment - i do it now

1 Like

I use Vivaldi and keep 10 tabs open, plus Thunderbird. This is my default workflow with no issues as you can see.

Here is top

Hope it helps.

2 Likes

hi - here the output with only one single vivaldi tab open

You could create a swap file. I use zram of 9Gb (8gb for the ram + 1Gb for hibernation). You could create a 5Gb zram swap file. My swap is not even being used in the screenshots I posted. You should be fine with what you have.

2 Likes

How much is the RAM usage on fresh boot?

Reboot, and then just run htop in a terminal.

Also adding some swap space might alleviate the issue (mentioned already by @HMS_Endeavour while I was typing :turtle:)

1 Like