EndeavourOS Not working properly

No matter how I tried, it will eventually become like this, I am using the offline version, I tried to install on the basis of win7, can display the system, but the brackets inside the display is not successful


Try “UEFI: Generic Flash Disk”.

It says the drive is not present, so it seems like it is a previous entry not being removed.

Edit:

Are you trying to boot from USB or did you already install it?

i already install it
yes. it is a previous entry not being remove
when i install it after

What happens if you select the SATA entry?

Can you boot from EndeavourOS USB and send the output of

sudo fdisk -l

that win7

What’s it?

When you boot the live USB, before installing eos, you can find a log tool. It should either be on the left in the xfce task bar or in the welcome menu, then send some system information to get help installing it.

Basic information missing:

  1. is the system a legacy BIOS (older) or new EFI system?
  2. is secure booot disabled and legacy boot disabled for internal drives and usb (CSM)?
  3. you can boot into installer ISO?
  4. you try to boot into an installed system or try to reinstall ?
1 Like

It is a command. Boot EnOS live ISO, start terminal and type that in, send the output of it.

–——————BLOS(older)
YES
you can boot into installer ISO? ——YES
I cann’t to boot into an installed system,

this is log


From the image of the Boot selection menu, it seems it is a UEFI system.
If you want assistance, you have to give more technical details, so we can give you the proper advice.

  • Boot into the USB/ISO installer.
  • Start a terminal
  • Run these commands
efibootmgr -v
sudo inxi -dapuo
  • Copy all the text in the terminal (commands and output) and paste it here, using the code formating button </> in the post toolbar.

No Images for text content, Please!

[liveuser@eos-2022.06.23 ~]$ efibootmgr -v
BootCurrent: 0005
Timeout: 1 seconds
BootOrder: 0006,0001,0005,0007,0000,0003,0002
Boot0000  endeavouros-9822	HD(1,MBR,0x580345cb,0x800,0x12e3f110)/File(\EFI\endeavouros-9822\grubx64.efi)
Boot0001* 硬盘 	BBS(HD,,0x0)AMGOAMNO........m.S.T.5.0.0.D.M.0.0.2.-.1.B.D.1.4.2....................A.........................>..Gd-.;.A..MQ..L. . . . . . . . . . . . .3.W.B.T.B.7.M.9......AMBOAMNO........w.G.e.n.e.r.i.c. .F.l.a.s.h. .D.i.s.k. .5...0.0....................A.......................J..Gd-.;.A..MQ..L.C.C.B.B.1.1.0.7.2.5.2.2.1.6.3.5.0.3.0.0.3.5.3.1.0.7......AMBO
Boot0002  endeavouros-3566	HD(1,MBR,0x580345cb,0x800,0x12e3f110)/File(\EFI\endeavouros-3566\grubx64.efi)
Boot0003  endeavouros-4219	HD(1,MBR,0x580345cb,0x800,0x12e3f110)/File(\EFI\endeavouros-4219\grubx64.efi)
Boot0005* UEFI: Generic Flash Disk 5.00	PciRoot(0x0)/Pci(0x13,0x2)/USB(1,0)/HD(1,MBR,0xab3ab792,0x369fc0,0x33000)AMBO
Boot0006* endeavouros-8851	HD(1,MBR,0x580345cb,0x800,0x12e3f110)/File(\EFI\endeavouros-8851\grubx64.efi)
Boot0007* UEFI: ST500DM002-1BD142	PciRoot(0x0)/Pci(0x11,0x0)/Ata(0,0,0)/HD(5,MBR,0x0,0x39985800,0x9ff800)AMBO
[liveuser@eos-2022.06.23 ~]$ sudo inxi -dapuo
Drives:
  Local Storage: total: 469.57 GiB used: 0 KiB (0.0%)
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500DM002-1BD142
    family: Barracuda 7200.14 (AF) size: 465.76 GiB block-size:
    physical: 4096 B logical: 512 B sata: 3.0 speed: 3.0 Gb/s type: HDD
    rpm: 7200 serial: W3TB7B9M rev: KC48 temp: 37 C scheme: MBR
  SMART: yes state: enabled health: PASSED on: 249d 22h cycles: 2709
    read: 263.95 GiB written: 1.94 TiB Pre-Fail: reallocated sector: 100
    threshold: 36 attribute: Spin_Retry_Count value: 100 worst: 100
    threshold: 97
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Generic model: Flash Disk
    size: 3.81 GiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: CCBB1107252216350300353107 rev: 5.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: N/A size: 10 GiB used: 58.8 MiB (0.6%) fs: overlay
    source: ERR-102
Unmounted:
  ID-1: /dev/sda1 maj-min: 8:1 size: 151.12 GiB fs: ntfs
    uuid: 01D5F36B3DC1A9D0
  ID-2: /dev/sda2 maj-min: 8:2 size: 1 KiB fs: N/A uuid: N/A
  ID-3: /dev/sda5 maj-min: 8:5 size: 112.67 GiB fs: ntfs
    uuid: 01D5F36B23786280
  ID-4: /dev/sda6 maj-min: 8:6 size: 96.32 GiB fs: ntfs
    uuid: 01D5F3691D0721E0
  ID-5: /dev/sda7 maj-min: 8:7 size: 60.64 GiB fs: ntfs
    uuid: 01D5F368B083BE70
  ID-6: /dev/sda8 maj-min: 8:8 size: 5 GiB fs: vfat uuid: 80A9-2661
  ID-7: /dev/sda9 maj-min: 8:9 size: 40 GiB fs: ext4
    uuid: 99fb7cea-a12f-484f-b127-45eff53c525f
  ID-8: /dev/sdb1 maj-min: 8:17 size: 1.71 GiB fs: iso9660
  ID-9: /dev/sdb2 maj-min: 8:18 size: 102 MiB fs: vfat uuid: C7B3-C190
[liveuser@eos-2022.06.23 ~]$ 

now
this http://www.termbin.com/xnsq

2022-07-29 - 13:36:49 [6]: [PYTHON JOB]: "Bootloader: grub (efi)" 
2022-07-29 - 13:36:49 [6]:     .. Running ("grub-install", "--target=x86_64-efi", "--efi-directory=/boot/efi", "--bootloader-id=endeavouros-9415", "--force") 
2022-07-29 - 13:37:14 [6]:     .. Target cmd: ("grub-install", "--target=x86_64-efi", "--efi-directory=/boot/efi", "--bootloader-id=endeavouros-9415", "--force") Exit code: 1 output:
 Installing for x86_64-efi platform.
grub-install: warning: /boot/efi doesn't look like an EFI partition, system may not boot.
Could not prepare Boot variable: Function not implemented
grub-install: error: efibootmgr failed to register the boot entry: Input/output error.
2022-07-29 - 13:37:14 [2]: WARNING: [PYTHON JOB]: "Command 'grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=endeavouros-9415 --force' returned non-zero exit status 1." 
2022-07-29 - 13:37:14 [6]: [PYTHON JOB]: "stdout:Installing for x86_64-efi platform.\ngrub-install: warning: /boot/efi doesn't look like an EFI partition, system may not boot.\nCould not prepare Boot variable: Function not implemented\ngrub-install: error: efibootmgr failed to register the boot entry: Input/output error." 

relevant part from installer log.

What’s mean
sorry,my English really bad
now it cannt installer

I miss still a complete partition output or at least info on how partitions are setup in calamares?

Uploading: IMG_20220729_163118.jpg…


I would bet windows is not installed in efi mode?.. as i do not see an ESP from windows.
So it could be that the drive is not gpt and uses mbr scheme.
Aside from that i see you have /home set to 1GB this is to small… and in addition you have /boot partition what is not needed (same for /home) only if you need that by reason it could make sense.


2022-07-29_10-59