Endeavouros Install Stalls

I recently tried to reinstall Endeavouros on my Intel NUC5CYPH (4GB RAM) - secondary machine. I had been experimenting with Kubuntu for fun and then decided it was time to return to a serious distro. Instead of doing a clean Arch install, I downloaded your latest Endeavouros iso, did the md5sum and dd’d it to a usb stick. I fired up the USB stick and it booted into Endeavouros - almost. At the point where the desktop should appear, all I got was a pointer on a black screen. Nothing else happened. I did that twice - same result.

I expect you have some idea why it won’t load on my computer. I gave up and did a clean, vanilla Arch with Openbox. Any ideas?

Where did you download the ISO from?

Hi Elloquin
I downloaded it from the Endeavouros website Downloads page.

Hi Welcome @davidw, you could give a log file at the end of install to find if there is something wrong.

Did you desactivate your secureboot ? then give us more info about your partition schema, you did it on Calamares or Gparted ?

As I wrote, the USB stick with the installer ISO didn’t even boot into the welcome screen. I’ve done dozens of installations of Arch, Endeavour and others on my two linux computers.

You didn’t answer @FLVAL ‘s question :hugs:

If you did a dozen of Arch installations we don’t have to help you to make your USB stick works. But to be sure, I do it simply this way and never got any problems to boot on it :

sudo dd bs=4M if=/home/username/Documents/endeavouros-2020.07.15-x86_64.iso of=/dev/sdx status=progress && sync

Do you install throw VBox / VMware or baremetal ?

2 Likes

does ventoy works with endevouros ?

2 Likes

Apparently yes :grinning:

Screenshot from 2020-07-25 16-13-04

1 Like

@davidw

Change the USB stick or USB stick recorder; popsicle is very good, it’s in AUR

3 Likes

Thanks to all the suggestions. I think this version of EndeavourOS Installer is just incompatible with my Intel NUC5CYPH. I booted the live USB on my Asrock Deskmini A300 (AMD Ryzen 2200G) and it booted perfectly into the Welcome Screen. When the live usb starts it signals ‘secure boot disabled’ so I rechecked that on my Intel NUC. In the NUC’s BIOS the secure boot is unchecked so that is not the problem. I have installed Arch with Openbox and Herbstluftwm on my Intel NUC, so the computer works fine.
The Endeavouros installers have had occasional issues in the past and this looks like another one for me.

1 Like

Do you install throw VBox / VMware or baremetal ?

Try to remove quiet in your boot options.

Bare metal. I’ll try that later, thanks.

1 Like

Did you update the board BIOS prior to installation?

Give us the result of :

inxi -M

About your latest Bios update, I will see it more below refering to NUC5CYPH which is not in the list UP from @FortCollins :

BIOS Update [PYBSWCEL.86A]

Version: 0079 (Latest) Date: 4/20/2020

2 Likes

I typed my computer incorrectly. It’s an Intel NUC5CPYH. Anyway there appears to be a BIOS update for any operating system (not just Windows), but I don’t know whether I should do it since the computer is running OK apart from this problem. BTW inxi -M produced ‘command not found’.

No I don’t update the BIOS if the computer is running OK.

Have you ventured into the Arch wiki?

Well, I’d like to thank you and FLVAL for your advice. I downloaded the latest BIOS upgrade and flashed it to my Intel NUC5CPYH. It flashed the upgrade apparently OK. Now when I try to start up, there is no signal to the HDMI monitor until the LightDM greeter appears. I cannot get into the BIOS with F2 so I am unable to do anything other than run the existing system.

It looks like this is one computer for the scrap heap!!!

Do you have fast boot enabled?

To check:

  • make sure your computer is completely turned off.
  • hold the power button for 3 seconds and release it.
  • you’ll enter the power button menu.
  • press F3 to disable fast boot.
  • restart and hit f2
1 Like