EndeavourOS gone after BIOS update

Here is what happens:

I used bcdedit to add grub from Windows 10
Now This only works if I boot into BIOS first then proceed to boot
If I normal power on it directly boots in Windows
There is no EnOS entry in boot menu in BIOS

I tried to use EFI manager but it goes away after startup

What can I do

You should be able to go into your bios and set the endeavouros entry to boot by default. If it isn’t there, you can reinstall grub. That should re-add it.

1 Like

I had the same problem some time ago. It seems a BIOS update sometimes leads to the BIOS not being able to detect current OS entries at all. So it’s not possible to boot it from the BIOS. In my case even booting with the arch iso, mounting drives and reinstalling/configuring GRUB didn’t do the trick.

I actually had to reinstall arch completely, which I found weird, because in the end it does the same as doing the GRUB reinstall. Just sharing my experience.

Shouldn´t it be


At least it looks like this for me.


Replace the default efi file with EnOS/grub file

sudo cp -bs ".win" /boot/EFI/efi/endeabouros-6060/grub64.efi /boot/efi/EFI/Boot/bootx64.efi

If anyone wonders about capitalization in file/dir names, vfat/FAT FS is case insensitive.

I think you are right, if $ESP is mounted on /boot/efi and not on /boot. I suppose, when OP runs the command, he"ll find out :rofl: .
Or he could check fstab… :wink: and modify if needed.

Sadly this is not a general rule. Many UEFI models do not provide this functionality. In such cases, the only way is to replace the default disk EFI entry, just like on removable drives.

All these are posted in Archwiki, long time ago.

I don’t have this issue and i chalk it up to poor implementation of UEFI.

1 Like

or maybe smart, to promote a specific well known OS. :wink:

Ok I see the EOS entry now in BIOS

But the WIndow issues still there when I reboot from Windows it does not show grub

That’s because Windows is not actually rebooting the machine. You’ll need to power off fully then boot, and/or disable Windows’ Fast Boot “feature”.