EndeavourOS fix for ESP handling in mount?

@dalto
Do you see this fix making into upstream Calamares?
[mount] Fix ESP handling and add option for skipping SE Linux :

I just encountered this problem when changing over to Calamares 3.3.5 and the fstab.conf is no longer used to set mount options. I discovered that changing the mount.conf file to read:

mountOptions:
- filesystem: default
options: [ defaults ]
- filesystem: vfat -----> notice using the filesystem type vfat instead of “efi”
options: [ defaults, umask=0077 ]

gets around the problem of applying the desired options to the efi mount in fstab. I did not expect EndeavourOS to solve the problem in the way they did. It looks like the EndeavourOS fix should make it upstream.

If memory serves, that code is only needed because our EFI partition mount point changes based on the bootloader selected.

I am not quite following what the issue you are trying to solve is. Can you explain the challenge you have?

When I use the example:

mountOptions:
    - filesystem: default
      options: [ defaults ]
    - filesystem: efi
      options: [ defaults, umask=0077 ]
    - filesystem: ext4
      options: [ defaults, noatime, nodiscard ]
    - filesystem: btrfs
      options: [ defaults, noatime, nodiscard, noautodefrag ]
      ssdOptions: [ ssd ]
    - filesystem: btrfs_swap
      options: [ defaults, noatime ]

And I have the ESP mounted to /efi, the options I specify do not get applied in the fstab to the ESP of the installed system. If I change:

    - filesystem: efi
      options: [ defaults, umask=0077 ]

to:

    - filesystem: vfat
      options: [ defaults, umask=0077 ]

Then the options do get set properly.

Yeah, after looking at it, that is a bug upstream. I am surprised nobody has noticed that yet.

I will fix that this weekend.

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.