Endeavouros doesn't boot anymore

Hi all,
I have been using Endeavouros for a couple day without any issue. However, today my laptop when into hibernate and since then it doesn’t reboot.
I have this black screen with the flicking underscore. After a bit of research I manage to log in with command line interface.
After looking at the journal it seems the issue is with lightdm.service
I ran it in debug test mode but I struggle to understand where the problem is coming from. It seems to stop from “Stopping; failed to start a greeter”.

I think I have pushed the limit of what I can figure out by myself, any help is welcome! As mentioned, I did not install or did anything, my laptop going to sleep/hibernate seems to have caused that.

EDIT: I still cannot find the issue but I manage to extract the log (sorry it took time I am a new user of Linux): journal and here is the hardware


If you are able to log in to a TTY then check lightdm status.

systemctl status lightdm

Edit: You can try

systemctl enable lightdm
systemctl start lightdm

Thanks, I can get into TTY by adding a “3” in Grub.

The status gives me:
Loaded: (/usr/lib/systemd/lightdm.service; enabled; preset: disabled)
Active: inactive (dead)
Docs: man: lightdm(1)

I then try to start it and I am back to the initial issue of black screen with a non regular flickering underscore.

I don’t know if it helps but here is a picture of the journal. It seems like it keeps trying to run lightdm.service

How did you add a 3 to grub without a tty in the first place if you can’t get to anything bboot a black screen?

Where did you put the 3? How did you update grub? I’m very lost.

What desktop is installed? Have you tried to update when in a TTY?

I used that to get into the console: https://www.linuxuprising.com/2020/01/how-to-boot-to-console-text-mode-in.html?m=1

My laptop is booting into Grub (note I can get into Windows).

I use Xfce.
Yes, I did a pacman -Syu but it did not solve the issue.

I also check that [LightDM] logind-check-graphical was set on true in /etc/lightdm/lightdm.conf as suggested here https://wiki.archlinux.org/title/LightDM#Troubleshooting but it did not solve my problem.

Welcome to the forum! :smile:

You could test another display manager like sddm:

sudo pacman -Syu sddm
sudo systemctl disable lightdm
sudo systemctl enable sddm

Thanks, I managed to get to the login gui screen but when I type my password and press enter nothing happen. My cursor is now a cross and cannot do anything

I hope this will help, this is the output of journalctl -b -0 - link here
And here is the hardware information

Ok, problem solved: my linux partition was full…
I wanted to thank you all for your help and reactivity!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.