EndeavourOS crashing

Hi guys,

First of all, I love EndeavourOS, I have used it for months without any issues. I use it on VM Ware virtual machine.
But since the last couple of months, the system crashes after a few days, basically, after an update, every time I get a message that I need to reboot. After a reboot, I get the message:
error: file /boot/vmlinuz-linux not found

Since I don’t know how to fix the system, I reinstall it and start again. I have done this 5 times in the last couple of months.

I don’t install random stuff from AUR, I use it to SSH into my server, and to practice console with light office usage.

What am I doing wrong here? Why is it so unstable?

I use UK and EU mirrors from Germany and some other countries.

can you check to see if that file is in /mnt, 'cause it should be in /boot. The first thing that popped up when i searched “boot/vmlinuz-linux not found” was this, which seems about right:
https://bbs.archlinux.org/viewtopic.php?id=217104
(so personally, i’d just copy and paste it into /boot as a starter, and see if that did the trick, and if not, follow the link)

Maybe you can use the live usb ISO and arch-chroot into your installed system and update or if necessary reinstall grub and up date it. Maybe add the US mirrors also. Not sure if you are having updating issues with mirrors. You cannot interrupt updates or do a partial update with Arch. Things go bad real fast.

Thanks for the help guys!
I have one weird problem, to access the bios in VMWare I have to press F2 before the system loads, so I can set up boot order, but the system loads so fast that I cant manage to hit F2 on time :joy:
I actually have to hit Fn+F2… sooo bad

I have googled this, but on official VMWare docs, there is no other method to change boot order, or I just can’t find it.

I’m not sure i understand what you are saying. To access the Bios FROM vmware? I boot the computer to access the UEFI bios on boot. Is this what you actually mean? On my system it is the F11 key to change the boot order or enter Bios setup… I’ve never entered Bios in vmware. :thinking:

This seems like a strange problem to repeat itself so many times. I have multiple Arch installations in Virtualbox that update just fine for the last several months. Are you using an emulated UEFI setting in your virtual machines? If so, I would suggest not bothering with UEFI/EFI in VM’s as there is no benefit there. Are you letting the update process complete fully, letting the disk get written to completely before rebooting?

I use UEFI on my vm but my host is UEFI. No issues. I use both v-box and vmware.

Hi, I’m using BIOS in the settings. I have never interrupted an update. One thing I have noticed is that for some reason open-vm-tools stopped working properly, even on a fresh installation. I know this worked out of the box for Endeavour, but lately, even after a fresh install open-vm-tools process was not starting properly so I had to manually restart it every time I boot into the system.
I use an online installer to install Endeavour OS + Gnome.
I thought this may be due to some issues with Win11 host, or some Dell drivers issue (they have driver updates very often) but not sure

Have you tried other kernels? Maybe the LTS kernel? Have you tried other Arch based distros? Does this happen when using Arch itself? This just seems strange to be happening all of a sudden on every installation attempt.

You say you are using Gnome. Are you using a Wayland session or Xorg? Does the problem present in both environments?

Sorry for the late reply. I have always used standard kernel, to be honest, I have never even thought to use any other. I have installed Arch to check it, I hate installing Arch, one of the reasons I think EndeavourOS is so good is a quick install. I have installed Arch 4 days ago, basic BIOS install (i did this many times before), and while I was typing this I did pacman -Syu and it is dead now.

Screenshot 2022-03-23 085445

Arch does not like me

really strange nothing more i can say about :wink:
Do you use a single drive or a split drive on VMware? i test installs regular on VMware and never had this issue.

Yes, just strange, I will probably wait for a new version of EndeavourOS before I install it again.

My VMWare installation for EndeavourOS/Arch:

  •   I create a single partition to install system (but i use **split partition option in VMWare**),
    
  •   I do not use SWAP,
    
  •   I do BIOS install,
    
  •   I use EXT4 as a filesystem,
    
  •   VMWare Workstation Pro 16 16.2.3 build-19376536,
    
  •   Host: Windows 11 21H2 22000.556
    

I can share an image if someone wants to have a closer look but if this is such a rare problem maybe it is pointless to waste time.

I use vmware so i can’t understand what your problem would be.

Edit: I am not sure of your process for installing it on vmware but there are two methods to installing in Bios actually 4 if you were dual booting with Windows on UEFI and using GUID partitioning. You said you didn’t use swap and only had a root partition. In that case your partitioning scheme would look like this.

Drives:
  Local Storage: total: 18 GiB used: 6.06 GiB (33.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: VMware model: Virtual S size: 18 GiB
    block-size: physical: 512 B logical: 512 B type: N/A serial: N/A rev: 1.0
    scheme: MBR

I don’t know exactly what your issue is. But if you created the partition manually and you didn’t flag it properly it won’t boot. It could also be something in your setting on vmware? Or another issue.

Edit:

1 Like

If this were on the hardware (not VM), I’d say probably a hardware issue. Maybe it still is.

Yes, you are right, that is exactly how it looks like on a fresh install

Guys thank you all for your time, I see that there is a great community here.
I don’t think there is a solution for this without some serious digging, but this is not worth the time. I am glad to hear that this is not a widespread issue.
I will try again and see what it looks like, maybe I can try XFCE or KDE edition and just see.
Thanks!