EndeavourOS as Web Server

Hi, currently i am using Ubuntu LTS in My web servers.

Can i use Endeavouros with LTS kernel in Web Server

Has anyone using EOS or arch as Web Server?

I have a ARM RPi 4b web server using Arch base ( headless ) and nginx. It also uses Let’s Encrypt for the certificate.

It is strictly a static web file server. No MySQL, PHP or anything fancy. There is nothing critical on the web server.

Works great and only draws 5 Watts as measured at the 120 VAC receptacle.

Pudge

2 Likes

A constantly updating distro is not usually the first choice for any kind of server - lts kernel or not! However…

I myself can’t think of anything more stable than EnOS has proven to be over the past year or so - with the single exception of the possibility of a ‘bad’ update. I have a work-around for that :grin:

Essentially what I do is to use eos-shifttime (in the EnOS repo) to utilize the Arch archive system to update UP TO the prior week (if date is the 10th, I update to the state of things on the 3rd) - thus leaving time for dealing with any fixes that turn out to be needed before applying them to the server. More on how it works can be found out in our Wiki, or in eos-apps-info (also in the repo).

What is the server? I run a dual mirror setup, with EndeavourOS repo and chaotic-aur repo available 24/7 as needed (except for the 5 minutes updating once weekly)

4 Likes

yes, no problem … but I use it privately @ home for php coding

that seems a cool way to go, so forget fedora :sunglasses:

Yep. Some twit wrote this: Local LEMP development [Tutorial]

I’m switching my Ubuntu VPS to EndeavourOS as I got tired of dist-upgrades & it gives me an excuse to learn ansible.

For a very minimal system you only need selected from the base-devel options in the “desktop” stage of the Calamares Installer:

  • Network/dnsutils

  • Network/net-tools

  • packages management (all)

  • filesystem/unzip

  • filesystem/xz

Once the system boots check the name of your ethernet NIC in /sys/class/net (probably enp1s0) & run:

  • ip link set $iface_name up

Create /etc/systemd/network/20-ethernet.network:

[Match]
Name=en*
Name=eth*

[Network]
DHCP=yes
IPv6PrivacyExtensions=yes

[DHCP]
RouteMetric=512

& finally run as root:

systemctl enable systemd-networkd
systemctl start systemd-networkd

Install EndeavourOS on btrfs so it’s easy to setup snapper

Run services inside lxd containers for extra security (Alpine Linux containers are a good choice - lightweight & easy to update from version to version)

The bare metal system is so minimal there should not be much to go wrong (except perhaps lxd - but due to running Arch there is no need to run snapd to get lxd running)

I run encrypted systems & was pleasantly surprised how quickly the system boots (1 second)