Endeavour os Shows Limited Connectivity in Network manager after following a tutorial on reddit

EndeavourOS show limited connectivity for both ethernet and wifi after following a tutorial on reddit for things to do after installing EndeavourOS.

I am providing a link to reddit thread
Reddit thread

Last I remember the internet was working fine till I removed the thumbnail viewer package

With following command

sudo pacman -R ffmpegthumbnailer

And tried to install


In step 5, it recommends installing ufw, but EndeavourOS has firewalld as its default firewall (unless you deselected this when you installed EndeavourOS). So, you might be running two firewalls…

What is the output of

systemctl status firewalld

If it is showing as active (running) then uninstalling either ufw or firewalld would be a very good idea (and rebooting of course).


Thanks a lot, that was it. i ran the following commands
in the listed order

systemctl status firewalld
sudo systemctl disable ufw
sudo ufw disable
sudo systemctl disable --now ufw.service
sudo pacman -Rcns ufw plasma-firewall
systemctl reboot

to uninstall and deactivate ufw and

firewalld shows active

1 Like

There´s a new version of this Todo list.

Nevertheless I stopped reading at this point…

  1. Manjaro’s GUI Package Manager :-

#Many users prefer GUI package managers and Manjaro’s pamac works really well with AUR support

yay -S pamac-all


Hey thanks for liking new version, but i think i should read about everything before tweaking it.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.