Endeavour OS failes to boot due to a kernel panic, as well as an installer error when replacing a partition

Hi! I attempted to install the KDE Plasma environment from a live iso on a usb stick. The instillation worked on one computer, using a different environment, but now i have attempted to install it on my desktop pc, replacing kde neon, i have had a few errors and have been unable to successfully boot the os

Firstly, i attempted two times to install the os over an existing partition, only for a crash to occur and a response informing me that it had failed to edit the partition. i will get the logs again in a few mins.
secondly, i set it to install on an existing, rather than unallocated space (roughly 135gb) and the install went through without a crash, but when i boot i get the following comments:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block (0,0) ]--

, I have a dual-booted pc, containing linux mint (which i am messaging from now), and win7
all logs are located at https://pastebin.com/uacUXvyC , with the 3 commands + the 2 links at the bottom of the paste, as one failed
Any advice?

How did you create the live usb?

Edit: There 15 newer Bios updates for your motherboard. I would strongly suggest that you update the Bios also to the latest version.

2 Likes

Hi! Thanks for the tip regarding the motherboard :slight_smile: !
I created the live usb using etcher, on win7, which worked for mint and kde neon fine, aside from 1-2 grub issues.

Etcher should be fine. If you only have Win7 and Mint on the computer and you are trying to replace Mint with EOS then it shouldn’t be an issue. You can just use replace a partition on the installer. I still recommend you update your Bios first and start from there.

Is csm and legacy disabled in bios? Saw something as no esp and “dos” for sda2 the no esp was on the other clbin…

What is fdisk -l ?

Tried that command, seems that a standard user also had an issue, check this: https://pastebin.com/ZmHk3NAR

seems to this list you want a efi install on a mbr.

https://clbin.com/b5ixK

mine…(fdisk -l)

calamares does have issues with csm or legacy options in bios

Cheers for the advice, updated my BIOS and managed to install and load without any issues, loving the looks and customization, but still typing ubuntu commands :rofl:

2 Likes

Add these to your aliases :rofl:

alias apt-get='man pacman'
alias apt='man pacman'
1 Like

Garuda afaik actually does put the first alias into the shell rc.

I got it from there :rofl:.
It was in their .zshrc. My .zshrc is based on theirs. But I removed the aliases I don’t need.