Endeavour OS boot only in failsafe mode

Hi,
I have triple boot Windows, Zorin and Endeavour OS. Grub is installed in Zorin. Whenever I choose Endeavour from Grub menu the screen goes blank. However, when I choose Endeavour failsafe mode then it boots without any problem.

Can anyone please advice how to resolve this issue and make Endeavour OS boot normally.

Thanks

Faisal

Working blind here - but my suspicion is that the easiest fix is to have EndeavourOS handle the grub. The ‘unmodified’ os-prober will NOT make a proper entry for EndeavourOS (or any Arch-based system) by itself. If you look in the grub entry (/boot/grub/grub.cfg) you will probably see something like this at the end:

	initrd	/boot/amd-ucode.img 

instead of the correct

	initrd	/boot/amd-ucode.img /boot/initramfs-linux.img

It is a tricky task to fix this - especially so it stays fixed! - thus the recommendation for letting EnOS handle the grub, because it knows how…

Hope this helps! And welcome to the purple side of Arch!

1 Like

You may give rEFInd a try. In setups > dual boot this is a good and almost maintenance free solution, see the wiki by @freebird54 here.

1 Like

If Zorin’s grub entry for EndeavourOS is incorrect as @freebird54 suggested, then you can use EndeavourOS’s grub in charge.

Another way is to fix grub.cfg in Zorin by writing a new file /boot/grub/custom.cfg where you copy the EndeavourOS entry from /boot/grub/grub.cfg and make the change @freebird54 suggested (add the microcode parameter) to the new file. Then, when you reboot, choose the new EndeavourOS entry.