EndeavouOS keeps freezing

EndeavourOS keeps freezing

I have been using EndeavourOS for quite some time but for the past few days it has been freezing and the audio sounds crappy. I think this maybe caused by pipewire so i tried moving to pulseaudio but I cant firgure out how to do that

I hope someone here can help me because this has been my favourite distro so far

Welcome to :enos: !!

Please provide us your hardware info and boot logs as per this article:

Also provide more details. When is it freezing? Is it during a specific app. More information is always appreciated.

Hello @radek8011, and welcome to the EndeavourOS community!

:enos: :penguin_face:

Welcome to the forum @radek8011 :enos: :enos_flag: :partying_face:

Heyy, thanks for the reply, I don’t check the forum much and have been occupied with exams so I was unable to respond

https://clbin.com/Flo9W

I have included the necessary logs here
(I apologise in advance if I messed up somewhere and included a bit too much info)

The system usually froze when I was using the browser for something and generally after I started playing some media like a video online or offline or playing music

Sound Server-2: PulseAudio v: 16.0 running: yes
Sound Server-3: PipeWire v: 0.3.52 running: yes

You would need to choose one or the other. Please refer to the relevant articles for How-To:

https://discovery.endeavouros.com/?s=audio

Okay, any idea how do I disable pulseaudio then??

also, rn i am running endeavour and the audio sounds just fine! How do I check which sound servers are running right now?

Both are running as your output shows (also try: inxi -aA).
They might just conflict.

If you want to go with pipewire:

1 Like

sorry for being dumb but it doesn’t mention how to stop pulseaudio, I tried deleteing pulseaudio but it is required by a lot of other applications and same goes for pipewire

another problem that i am facing is significant input lag on both touchpad and keyboard, using Gnome on wayland in case you are wondering

do you know why that happens?

Let’s say you want to go with pipewire. Going by the instructions in the article posted above, what is the output of:

`sudo pacman -S --needed pipewire-pulse pipewire-alsa pipewire-jack wireplumber

Also you could try this for disabling pulseaudio:

systemctl --user disable --now pulseaudio.service

I’m afraid not. Hopefully other forum members who might know will chime in.

1 Like

Okay so I did a little digging and yea I believe the problem was pulseaudio and pipewire running side by side, I installed pipewire-pulse and it solved everything

thanks a lot pebcak :^)

1 Like

You are welcome!
Good to hear you got it all working!

And welcome to EnOS’ community!

:enos_flag: :handshake:t5:

1 Like

First time i have seen all 3 running? That is odd that that happened. Probably one package installed without it removing the other. :man_shrugging:

 Sound Server-1: ALSA v: k5.18.3-arch1-1 running: yes
 Sound Server-2: PulseAudio v: 16.0 running: yes
 Sound Server-3: PipeWire v: 0.3.52 running: yes

Apparently, not all pipewire components conflict with pulseaudio ones so they are not all removed.

For example you could have the package pipewire installed without it conflicting “package-wise” with pulseaudio:

pacman -Qi pipewire | grep -i conflicts
Conflicts With  : None

What was missing was the pipewire-pulse which indeed conflicts with both pulseaudio and pulseaudio-bluetooth:

pacman -Qi pipewire-pulse  | grep -i conflicts
Conflicts With  : pulseaudio  pulseaudio-bluetooth
1 Like

Apparently! I thought most of them conflicted and would be removed? Not so … as you have shown. :astonished:

You need to add dependency bugs to your Icon! :laughing:

There:

Screenshot from 2022-06-19 19-15-07

Work in progress … :wink: :rofl:

2 Likes

@pebcak

I messed up… so i moved the post out! :smile_cat:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.