EndeavorOS says it's about to boot up, then it throws an error

I am installing endeavorOS on my AMD PC using a Live USB (flashed in balenaEtcher), when I proceed to boot the fallback mode, it proceeds and sets-up everything, then it throws this error (refer to the image below)

My specs are here.
image

I have tried:

  • Adding noapic and iommu=soft

Please help me! Thank you!

can you please update the screnshot? It’s blurry and cut off…

Try adding nomodeset.

1 Like

Try adding this kernel parameter without the others.

amdgpu.dc=0


Apologies for the late reply.

Tried this, no luck. Still throws that same error.

will CNTL-ALT-F2 give you a new login prompt? From there, you’d have access to pacman to install/reinstall things that might be buggered up. Maybe even try “sudo pacman -Syu” and let it update itself and see what a reboot does.

Hi! Thanks for the reply. Yes, CTRL-ALT-F2 gives me a new login prompt, but I do not know what to do, because it asks me for a username & password. I’m really new to endeavorOS and arch in general, so I have no clue what to put there.

Looks like a bad write or download and the iso isn’t working for you. I would try again.

I don’t think it’s just this specific ISO, though. I already tried installing other distributions, same error. It’s either this, or black screen. I’ve already re-downloaded the ISO 2 times and burned it on my USB using balenaEtcher.

It’s interesting that other distros don’t work either. Etcher is fine.

Have you ever gotten any Linux distro to boot into the live iso? I mean literally any? Mint? Ubuntu? Manjaro?

Have you tried another USB? Maybe it’s bad. Or even tried booting it on another computer even?

In this computer, no. Litteraly ANY distro, Mint, Ubuntu, and Manjaro.

But on my my laptop, it does boot up. The Live USB i am using right now is the same one i used when I installed Manjaro on my laptop.

This is the only functioning USB i have.

@JamTheDev
Have you tried nomodeset as a kernel parameter in the default grub command line?

1 Like

Then it could possibly be some HW/firmware/BIOS configuration that breaks them.
Have you ever read your motherboard User Manual, and if so, what settings have you already altered to test for a change?

Is it this one, or I picked the wrong one?

1 Like

Would be interesting to see boot and verbose xorg-logs.
journalctl -b -0

The fact it boots on your laptop means the installation medium is working fine, so while it might not be the answer you want: it looks like this computer just isn’t compatible with Linux, and I’m not sure it’s fair to expect people here to try to solve an unsolvable problem.

On the other hand, a BIOS update might help. Or contact the manufacturer and ask why Linux doesn’t boot.

1 Like

there’s a couple of comments on this thread about adding nomodeset, but i didn’t see a response (sorry if there is one, i might have missed it). That used to work for me with a blank screen on a live boot with amd on a much older thinkpad with a dual vid chip with amd.

Neither radeon nor amdgpu are usable with nomodset, as Archwiki says.
Most cases I remember, while nomodeset made a non-booting system to boot, they were still unusable (black screen etc.).
That thinkpad of yours might be an exception(?). :slightly_smiling_face:

just mentioned it 'cause richlinux and mrvictory did and it wasn’t responded to before. The thinkpad i had wasn’t an exception at the time, just a good few generations ago (10 years back, doesn’t time just fly?).

1 Like

Ok, (sorry about the delay getting back) when you went through the installer, it should have asked you to provide a username and password. It should also have asked if you wanted your user password to also be your root password. Did that not happen?