EDID length is too small

Since updating the colord version to 1.4.7-1, I get this error message.
What does this mean?

colord[573]: failed to get edid data: EDID length is too small

This is the edid info from the monitor. It means it cannot read or interpret the info that it needs for colord version 1.4.7-1

Thanks…
Is this due to the colord version?
Because it only occurs after the update.
And what can I do about it?

Downgrade colord using downgrade command. I think it would be sudo downgrade colord and select the version you want to downgrade to.

Edit: You can also add it to the ignore list so it won’t upgrade for now.

Downgrading doesn’t help either.
Error still present…

Check /var/log/pacman.log and see what updates you got at that time this happened.

Edit: Not sure what is causing it.

Perhaps of interest:

https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=1368291

Thank you, I already knew that.
Is it possible that this is a software bug, because it is only occurring now…!
Or should it be a hardware problem?

I don’t know what else I can do?

I’m sorry, I am unable to help.

That package has updated to 1.4.7-2, try updating.

sudo pacman -Syu

Thanks for the info.
I have already updated, unfortunately no change :face_exhaling:

Is this an external monitor? What connection type?

Edit: What is the hardware? Is this a hybrid laptop or desktop?

Monitor is an external Acer XB271hu with DP connected.
The hardware is therefore a desktop.
GPU: Nvidia 2070 Super
CPU: i7-6700k

Have you tried changing the DP port or is there only one available?

There is only one DP connection

I suppose powering off the monitor and unplugging it for while and disconnecting the DP at the same time and then reconnecting and turning on everything makes no difference?

I’ll try it out tomorrow.
I have already changed the DP ports on the GPU.

So I can’t find any problems with the hardware. Everything works perfectly.

So, I’ve done that now and it doesn’t change anything.

Have you tried another monitor?

No, unfortunately I don’t have another one available.