During update: at-spi2-core and at-spi2-atk in conflikt. at-spi2-atk removing!?

hello dear friends,

on a notebook that was not updated for about two weeks i have the following message
during update: at-spi2-core and at-spi2-atk in conflikt. at-spi2-atk removing!?



Arch & EndeavourOS Update-Check:
:: Suche Arch & EndeavourOS nach Updates...
aom 3.4.0-1 -> 3.5.0-1
archlinux-keyring 20220831-1 -> 20220927-1
at-spi2-core 2.44.1-1 -> 2.46.0-2
bind 9.18.6-1 -> 9.18.7-1
cairomm 1.14.3-2 -> 1.14.4-1
dbus 1.14.0-1 -> 1.14.2-1
dnsmasq 2.86-2 -> 2.87-1
endeavouros-theming 12.0-1 -> 22.09.3.2-1
eos-bash-shared 1.28-2 -> 1.32-1
eos-lightdm-slick-theme 2.0-4 -> 3.0-1
eos-log-tool 1.4.15-1 -> 1.10-1
eos-quickstart 1.3-2 -> 1.3-3
eos-rankmirrors 2.3-1 -> 2.5-1
eos-translations 1.12-1 -> 1.17-1
expat 2.4.8-1 -> 2.4.9-1
f2fs-tools 1.15.0-1 -> 1.15.0-2
ffmpeg 2:5.1.1-3 -> 2:5.1.2-1
firefox 105.0-2 -> 105.0.2-1
firewalld 1.2.0-1 -> 1.2.1-1
flac 1.4.0-1 -> 1.4.1-1
fluidsynth 2.2.9-2 -> 2.3.0-2
fzf 0.33.0-1 -> 0.34.0-1
git 2.37.3-1 -> 2.38.0-1
glib-networking 1:2.72.2-1 -> 1:2.74.0-1
glib2 2.72.3-3 -> 2.74.0-2
glibc 2.36-4 -> 2.36-5
glibmm 2.66.4-1 -> 2.66.5-1
gnutls 3.7.7-3 -> 3.7.8-1
gobject-introspection-runtime 1.72.0-1 -> 1.74.0-1
grub 2:2.06.r322.gd9b4638c5-4 -> 2:2.06.r334.g340377470-1
gspell 1.10.0-2 -> 1.12.0-1
gtk3 1:3.24.34-1 -> 1:3.24.34+r156+g812b3930d0-1
hwdata 0.362-2 -> 0.363-1
hwdetect 2022.09-3 -> 2022.09-4
iana-etc 20220715-1 -> 20220915-1
imagemagick 7.1.0.48-1 -> 7.1.0.49-1
imlib2 1.9.1-1 -> 1.9.1-2
iproute2 5.19.0-1 -> 6.0.0-1
krb5 1.19.3-3 -> 1.20-1
libbluray 1.3.2-1 -> 1.3.3-1
libbpf 0.8.1-1 -> 1.0.1-1
libcap 2.65-1 -> 2.66-1
libdrm 2.4.113-2 -> 2.4.113-3
libffi 3.4.2-5 -> 3.4.3-1
libmaxminddb 1.6.0-3 -> 1.7.1-1
libnghttp2 1.49.0-1 -> 1.50.0-1
libopenmpt 0.6.5-2 -> 0.6.6-2
libva 2.15.0-6 -> 2.16.0-1
libwnck3 40.1-1 -> 43.0-2
libwpe 1.12.3-1 -> 1.14.0-1
libxtst 1.2.3-5 -> 1.2.4-1
libxxf86vm 1.1.4-5 -> 1.1.5-1
linux 5.19.9.arch1-1 -> 5.19.13.arch1-1
linux-firmware 20220815.8413c63-1 -> 20220913.f09bebf-1
linux-firmware-whence 20220815.8413c63-1 -> 20220913.f09bebf-1
linux-headers 5.19.9.arch1-1 -> 5.19.13.arch1-1
noto-fonts 20220607-1 -> 20220810-1
pacman 6.0.1-7 -> 6.0.1-8
pango 1:1.50.10-1 -> 1:1.50.11-1
pangomm 2.46.2-1 -> 2.46.3-1
parallel 20220822-1 -> 20220922-1
pcre 8.45-2 -> 8.45-3
pcre2 10.40-2 -> 10.40-3
pinentry 1.2.0-1 -> 1.2.1-1
python-psutil 5.9.1-1 -> 5.9.2-1
python-termcolor 2.0.0-1 -> 2.0.1-1
qt6-base 6.3.2-1 -> 6.4.0-1
qt6-declarative 6.3.2-1 -> 6.4.0-1
qt6-translations 6.3.2-1 -> 6.4.0-1
rsync 3.2.6-1 -> 3.2.6-2
sof-firmware 2.2.1-1 -> 2.2.2-1
sqlite 3.39.3-1 -> 3.39.4-1
srt 1.5.0-1 -> 1.5.1-1
systemd 251.4-1 -> 251.5-1
systemd-libs 251.4-1 -> 251.5-1
systemd-sysvcompat 251.4-1 -> 251.5-1
tracker3 3.3.3-1 -> 3.4.0-1
tzdata 2022c-1 -> 2022d-1
webkit2gtk 2.36.7-1 -> 2.38.0-2
welcome 3.34-1 -> 3.38-1
wpebackend-fdo 1.12.1-1 -> 1.14.0-1
xfce4-notifyd 0.6.4-1 -> 0.6.4-2
xkeyboard-config 2.36+89+g382c5feb-1 -> 2.37-1
xz 5.2.6-1 -> 5.2.7-1
yad-eos 12.0-1.3 -> 12.0-1.4
Root Passwort: 
:: Paketdatenbanken werden synchronisiert …
 core                            156,7 KiB   140 KiB/s 00:01 [--------------------------------] 100%
 extra                          1720,3 KiB   218 KiB/s 00:08 [--------------------------------] 100%
 community                         7,0 MiB   274 KiB/s 00:26 [--------------------------------] 100%
 multilib                        170,9 KiB   149 KiB/s 00:01 [--------------------------------] 100%
 endeavouros                      34,3 KiB  32,1 KiB/s 00:01 [--------------------------------] 100%
Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …
:: at-spi2-core und at-spi2-atk stehen miteinander in Konflikt. at-spi2-atk entfernen? [j/N]

That is interesting. If you accept it do you get other conflicts?

hello dear Dalto
many thanks for the quick reply. i will accept it

hello -yes it still is conflicting somewhat

see


Nach in Konflikt stehenden Paketen wird gesucht …
:: at-spi2-core und at-spi2-atk stehen miteinander in Konflikt. at-spi2-atk entfernen? [j/N] j
:: at-spi2-core und atk stehen miteinander in Konflikt. atk entfernen? [j/N]

What happens if you also say “Yes/Ja” to that one?

hello dear Dalto,

many thanks - i get back the following - see

Root Passwort: 
:: Paketdatenbanken werden synchronisiert …
 core                            156,7 KiB   140 KiB/s 00:01 [--------------------------------] 100%
 extra                          1720,3 KiB   218 KiB/s 00:08 [--------------------------------] 100%
 community                         7,0 MiB   274 KiB/s 00:26 [--------------------------------] 100%
 multilib                        170,9 KiB   149 KiB/s 00:01 [--------------------------------] 100%
 endeavouros                      34,3 KiB  32,1 KiB/s 00:01 [--------------------------------] 100%
Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …
:: at-spi2-core und at-spi2-atk stehen miteinander in Konflikt. at-spi2-atk entfernen? [j/N] j
:: at-spi2-core und atk stehen miteinander in Konflikt. atk entfernen? [j/N] j

Warnung: Zu wenig Spalten für Tabellenanzeige vorhanden
Pakete (87) at-spi2-atk-2.38.0-1 [Entfernung]  atk-2.38.0-1 [Entfernung]  aom-3.5.0-1
            archlinux-keyring-20220927-1  at-spi2-core-2.46.0-2  bind-9.18.7-1  cairomm-1.14.4-1
            dbus-1.14.2-1  dnsmasq-2.87-1  endeavouros-theming-22.09.3.2-1  eos-bash-shared-1.32-1
            eos-lightdm-slick-theme-3.0-1  eos-log-tool-1.10-1  eos-quickstart-1.3-3
            eos-rankmirrors-2.5-1  eos-translations-1.17-1  expat-2.4.9-1  f2fs-tools-1.15.0-2
            ffmpeg-2:5.1.2-1  firefox-105.0.2-1  firewalld-1.2.1-1  flac-1.4.1-1
            fluidsynth-2.3.0-2  fzf-0.34.0-1  git-2.38.0-1  glib-networking-1:2.74.0-1
            glib2-2.74.0-2  glibc-2.36-5  glibmm-2.66.5-1  gnutls-3.7.8-1
            gobject-introspection-runtime-1.74.0-1  grub-2:2.06.r334.g340377470-1  gspell-1.12.0-1
            gtk3-1:3.24.34+r156+g812b3930d0-1  hwdata-0.363-1  hwdetect-2022.09-4
            iana-etc-20220915-1  imagemagick-7.1.0.49-1  imlib2-1.9.1-2  iproute2-6.0.0-1
            krb5-1.20-1  libbluray-1.3.3-1  libbpf-1.0.1-1  libcap-2.66-1  libdrm-2.4.113-3
            libffi-3.4.3-1  libmaxminddb-1.7.1-1  libnghttp2-1.50.0-1  libopenmpt-0.6.6-2
            libva-2.16.0-1  libwnck3-43.0-2  libwpe-1.14.0-1  libxtst-1.2.4-1  libxxf86vm-1.1.5-1
            linux-5.19.13.arch1-1  linux-firmware-20220913.f09bebf-1
            linux-firmware-whence-20220913.f09bebf-1  linux-headers-5.19.13.arch1-1
            noto-fonts-20220810-1  pacman-6.0.1-8  pango-1:1.50.11-1  pangomm-2.46.3-1
            parallel-20220922-1  pcre-8.45-3  pcre2-10.40-3  pinentry-1.2.1-1
            python-psutil-5.9.2-1  python-termcolor-2.0.1-1  qt6-base-6.4.0-1
            qt6-declarative-6.4.0-1  qt6-translations-6.4.0-1  rsync-3.2.6-2  sof-firmware-2.2.2-1
            sqlite-3.39.4-1  srt-1.5.1-1  systemd-251.5-1  systemd-libs-251.5-1
            systemd-sysvcompat-251.5-1  tracker3-3.4.0-1  tzdata-2022d-1  webkit2gtk-2.38.0-2
            welcome-3.38-1  wpebackend-fdo-1.14.0-1  xfce4-notifyd-0.6.4-2  xkeyboard-config-2.37-1
            xz-5.2.7-1  yad-eos-12.0-1.4

Gesamtgröße des Downloads:              588,35 MiB
Gesamtgröße der installierten Pakete:  1483,83 MiB
Größendifferenz der Aktualisierung:      -3,26 MiB

:: Installation fortsetzen? [J/n]

OK, now “J” again.

hello dear dalto,
first of all - many many thanks - i did as adviced. AND now the process is running. Ill keep you informed.

i come back and write what went on and what happened.

hello dalto awesome - i did it and see what i have gotten back

see a snipped of that what happened.

(40/85) Aktualisiert wird yad-eos                            [--------------------------------] 100%
(41/85) Aktualisiert wird eos-translations                   [--------------------------------] 100%
(42/85) Aktualisiert wird eos-bash-shared                    [--------------------------------] 100%
(43/85) Aktualisiert wird flac                               [--------------------------------] 100%
(44/85) Aktualisiert wird eos-lightdm-slick-theme            [--------------------------------] 100%
(45/85) Aktualisiert wird eos-log-tool                       [--------------------------------] 100%
(46/85) Aktualisiert wird qt6-translations                   [--------------------------------] 100%
(47/85) Aktualisiert wird qt6-base                           [--------------------------------] 100%
(48/85) Aktualisiert wird qt6-declarative                    [--------------------------------] 100%
(49/85) Aktualisiert wird eos-quickstart                     [--------------------------------] 100%
(50/85) Aktualisiert wird eos-rankmirrors                    [--------------------------------] 100%
(51/85) Aktualisiert wird f2fs-tools                         [--------------------------------] 100%
(52/85) Aktualisiert wird libbluray                          [--------------------------------] 100%
(53/85) Aktualisiert wird libva                              [--------------------------------] 100%
(54/85) Aktualisiert wird srt                                [--------------------------------] 100%
(55/85) Aktualisiert wird pcre                               [--------------------------------] 100%
(56/85) Aktualisiert wird ffmpeg                             [--------------------------------] 100%
(57/85) Aktualisiert wird noto-fonts                         [--------------------------------] 100%
(58/85) Aktualisiert wird firefox                            [--------------------------------] 100%
(59/85) Aktualisiert wird gobject-introspection-runtime      [--------------------------------] 100%
(60/85) Aktualisiert wird firewalld                          [--------------------------------] 100%
(61/85) Aktualisiert wird fluidsynth                         [--------------------------------] 100%
(62/85) Aktualisiert wird fzf                                [--------------------------------] 100%
(63/85) Aktualisiert wird git                                [--------------------------------] 100%
(64/85) Aktualisiert wird glibmm                             [--------------------------------] 100%
(65/85) Aktualisiert wird grub                               [--------------------------------] 100%
:: To use the new features provided in this GRUB update, it is recommended
   to install it to the MBR or UEFI. Due to potential configuration
   incompatibilities, it is advised to run both, installation and generation
   of configuration:
     $ grub-install ...
     $ grub-mkconfig -o /boot/grub/grub.cfg
(66/85) Aktualisiert wird hwdetect                           [--------------------------------] 100%
(67/85) Aktualisiert wird imagemagick                        [--------------------------------] 100%
(68/85) Aktualisiert wird imlib2                             [--------------------------------] 100%
(69/85) Aktualisiert wird libbpf                             [--------------------------------] 100%
(70/85) Aktualisiert wird iproute2                           [--------------------------------] 100%
(71/85) Aktualisiert wird libopenmpt                         [--------------------------------] 100%
(72/85) Aktualisiert wird libwnck3                           [--------------------------------] 100%
(73/85) Aktualisiert wird linux                              [--------------------------------] 100%
(74/85) Aktualisiert wird linux-firmware-whence              [--------------------------------] 100%
(75/85) Aktualisiert wird linux-firmware                     [--------------------------------] 100%
(76/85) Aktualisiert wird linux-headers                      [--------------------------------] 100%
(77/85) Aktualisiert wird pangomm                            [--------------------------------] 100%
(78/85) Aktualisiert wird parallel                           [--------------------------------] 100%
(79/85) Aktualisiert wird python-psutil                      [--------------------------------] 100%
(80/85) Aktualisiert wird python-termcolor                   [--------------------------------] 100%
(81/85) Aktualisiert wird rsync                              [--------------------------------] 100%
(82/85) Aktualisiert wird sof-firmware                       [--------------------------------] 100%
(83/85) Aktualisiert wird systemd-sysvcompat                 [--------------------------------] 100%
(84/85) Aktualisiert wird welcome                            [--------------------------------] 100%
(85/85) Aktualisiert wird xfce4-notifyd                      [--------------------------------] 100%
:: Post-transaction-Hooks werden gestartet …
( 1/22) Creating system user accounts...
( 2/22) Updating journal message catalog...
( 3/22) Reloading system manager configuration...
( 4/22) Updating udev hardware database...
( 5/22) Applying kernel sysctl settings...
( 6/22) Creating temporary files...
( 7/22) Reloading device manager configuration...
( 8/22) Arming ConditionNeedsUpdate...
( 9/22) Updating module dependencies...
(10/22) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.19.13-arch1-1
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 5.19.13-arch1-1
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: qed
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: qla2xxx
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: qla1280
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful
(11/22) Reloading system bus configuration...
(12/22) Warn about old perl modules
(13/22) Fix 'grub' and 'os-prober' after upgrading either of them.
===> INFO: grub-tools / grub-fix-initrd-generation:
===> INFO: /etc/grub.d/30_os-prober changed. See file /var/log/grub-fix-initrd-generation.log.
===> INFO: /etc/grub.d/10_linux changed. See file /var/log/grub-fix-initrd-generation.log.
GRUB-Konfigurationsdatei wird erstellt …
Thema gefunden: /boot/grub/themes/EndeavourOS/theme.txt
Linux-Abbild gefunden: /boot/vmlinuz-linux
initrd-Abbild gefunden: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-fallback.img
Warnung: Zur Erkennung anderer bootfähiger Partitionen wird os-prober ausgeführt.
Dessen Ausgabe wird zur Erkennung bootfähiger Programmdateien und Erzeugen neuer Boot-Einträge verwendet.
Bootmenü-Eintrag für UEFI-Firmware-Einstellungen wird hinzugefügt …
abgeschlossen
(14/22) Check if user should be informed about rebooting after certain system package upgrades.
==> INFO: Reboot is recommended due to the upgrade of core system package(s).
(15/22) Updating fontconfig cache...
(16/22) Updating GIO module cache...
(17/22) Compiling GSettings XML schema files...
(18/22) Probing GTK3 input method modules...
(19/22) Updating icon theme caches...
(20/22) Checking which packages need to be rebuilt
(21/22) Updating the info directory file...
(22/22) Updating the desktop file MIME type cache...

AUR Update-Check:
:: Durchsuche AUR nach Updates...
 -> Fehlende AUR Pakete:  ipw2100-fw  ipw2200-fw
 es gibt nichts zu tun

Drücke ENTER um dieses Fenster zu schließen:

well that just a snipped of that what happened.

1 Like