Durante actualización, preguntas incomprensibles

Hola a todos,

A veces pamac hace preguntas durante la actualización que me resultan incompresibles.

[keos@keos-pc ~]$ yay -Syyu
[sudo] password for keos: 
:: Synchronizing package databases...
 core                  135.6 KiB   360 KiB/s 00:00 [----------------------] 100%
 extra                1650.4 KiB   706 KiB/s 00:02 [----------------------] 100%
 community               4.9 MiB   756 KiB/s 00:07 [----------------------] 100%
 multilib              160.0 KiB   495 KiB/s 00:00 [----------------------] 100%
 endeavouros            11.5 KiB   340 KiB/s 00:00 [----------------------] 100%
:: Starting full system upgrade...
 there is nothing to do
:: Searching databases for updates...
:: Searching AUR for updates...
 -> Flagged Out Of Date AUR Packages:  python-pyparted
:: 1 Packages to upgrade.
1  aur/pamac-aur-git  9.4.0.r9.gc2ffcd0-1 -> 9.4.0.r11.ga49fca5-2
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
==> 

Dice que para excluir paquetes marque por los números que tengan estos, esto creo entenderlo. Ahora bien, aquí en este caso al parecer solo hay un paquete (1) y para actualizar, no para excluirlo … realmente no entiendo la lógica de esto, no se que debo hacer.

Si marco ‘1’ (enter) … ¿no lo estoy acaso excluyendo?.

Gracias.

hello , you can just enter

Gracias por responder, bien, debo hacer ‘enter’ sin marcar 1 … pero, ¿debo entender que cada vez que aparezca esta opción mi respuesta debe ser: ‘enter’ en todos los casos?.

Observa ahora lo que continúa despúes de dar a ‘enter’… cada vez entiendo menos:

:: Checking for conflicts...
:: Checking for inner conflicts...
[Repo Make: 19]  docbook-xml-4.5-8  itstool-1:2.0.6-1  docbook-xsl-1.79.2-5  glib2-docs-2.64.1-1  python-lxml-4.5.0-1  python-pygments-2.6.1-2  python-anytree-2.8.0-1  gtk-doc-1.32+37+gefc3644-1  netpbm-10.73.31-1  gts-0.7.6.121130-1  graphviz-2.42.3-3  vala-0.48.2-1  ninja-1.10.0-1  meson-0.54.0-2  python-markupsafe-1.1.1-3  python-beaker-1.11.0-3  python-mako-1.1.2-1  python-markdown-3.1.1-4  gobject-introspection-1.64.0-1
[Aur: 1]  pamac-aur-git-9.4.0.r11.ga49fca5-2

==> Remove make dependencies after install? [y/N] 

… Bien, prosigo con ‘enter’ (aunque no comprendo) si se rompe desinstalo … solo para dejar constancia:

==> Remove make dependencies after install? [y/N] 
:: Downloaded PKGBUILD (1/1): pamac-aur-git
  1 pamac-aur-git                    (Installed) (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 

La saga continúa:

==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: Parsing SRCINFO (1/1): pamac-aur-git
[sudo] password for keos: 
:: Synchronizing package databases...
 core                              135.6 KiB   968 KiB/s 00:00 [----------------------------------] 100%
 extra                            1650.4 KiB  3.36 MiB/s 00:00 [----------------------------------] 100%
 community                           4.9 MiB  1255 KiB/s 00:04 [----------------------------------] 100%
 multilib                          160.0 KiB  1231 KiB/s 00:00 [----------------------------------] 100%
 endeavouros                        11.5 KiB   502 KiB/s 00:00 [----------------------------------] 100%
resolving dependencies...
looking for conflicting packages...

Packages (19) docbook-xml-4.5-8  docbook-xsl-1.79.2-5  glib2-docs-2.64.1-1
              gobject-introspection-1.64.0-1  graphviz-2.42.3-3  gtk-doc-1.32+37+gefc3644-1
              gts-0.7.6.121130-1  itstool-1:2.0.6-1  meson-0.54.0-2  netpbm-10.73.31-1  ninja-1.10.0-1
              python-anytree-2.8.0-1  python-beaker-1.11.0-3  python-lxml-4.5.0-1  python-mako-1.1.2-1
              python-markdown-3.1.1-4  python-markupsafe-1.1.1-3  python-pygments-2.6.1-2
              vala-0.48.2-1

Total Download Size:    20.90 MiB
Total Installed Size:  124.79 MiB

:: Proceed with installation? [Y/n]

Sigo con los ‘enter’ … lo que continúa no es apto para la comprensión de los seres humanos:

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 glib2-docs-2.64.1-1-x86_64       1353.9 KiB   795 KiB/s 00:02 [----------------------------------] 100%
 docbook-xml-4.5-8-any              83.9 KiB  1010 KiB/s 00:00 [----------------------------------] 100%
 itstool-1:2.0.6-1-any              18.9 KiB  0.00   B/s 00:00 [----------------------------------] 100%
 docbook-xsl-1.79.2-5-any         1373.8 KiB  1111 KiB/s 00:01 [----------------------------------] 100%
 python-lxml-4.5.0-1-x86_64       1520.9 KiB  1281 KiB/s 00:01 [----------------------------------] 100%
 python-anytree-2.8.0-1-any         45.6 KiB  14.9 MiB/s 00:00 [----------------------------------] 100%
 gtk-doc-1.32+37+gefc3644-1-any    294.9 KiB   776 KiB/s 00:00 [----------------------------------] 100%
 netpbm-10.73.31-1-x86_64         1858.8 KiB   881 KiB/s 00:02 [----------------------------------] 100%
 gts-0.7.6.121130-1-x86_64         194.9 KiB  1120 KiB/s 00:00 [----------------------------------] 100%
 graphviz-2.42.3-3-x86_64            7.8 MiB   692 KiB/s 00:11 [----------------------------------] 100%
 vala-0.48.2-1-x86_64                2.2 MiB   548 KiB/s 00:04 [----------------------------------] 100%
 meson-0.54.0-2-any               1029.7 KiB   385 KiB/s 00:03 [----------------------------------] 100%
 python-markupsafe-1.1.1-3-x86_64   22.4 KiB  0.00   B/s 00:00 [----------------------------------] 100%
 python-beaker-1.11.0-3-any         86.2 KiB   991 KiB/s 00:00 [----------------------------------] 100%
 python-mako-1.1.2-1-any           129.7 KiB  1137 KiB/s 00:00 [----------------------------------] 100%
 gobject-introspection-1.64.0...  1167.9 KiB   957 KiB/s 00:01 [----------------------------------] 100%
 python-pygments-2.6.1-2-any      1808.6 KiB   541 KiB/s 00:03 [----------------------------------] 100%
 ninja-1.10.0-1-x86_64             112.0 KiB   523 KiB/s 00:00 [----------------------------------] 100%
 python-markdown-3.1.1-4-any       111.4 KiB   424 KiB/s 00:00 [----------------------------------] 100%
(19/19) checking keys in keyring                               [----------------------------------] 100%
(19/19) checking package integrity                             [----------------------------------] 100%
(19/19) loading package files                                  [----------------------------------] 100%
(19/19) checking for file conflicts                            [----------------------------------] 100%
:: Processing package changes...
( 1/19) installing docbook-xml                                 [----------------------------------] 100%
( 2/19) installing itstool                                     [----------------------------------] 100%
( 3/19) installing docbook-xsl                                 [----------------------------------] 100%
( 4/19) installing glib2-docs                                  [----------------------------------] 100%
( 5/19) installing python-lxml                                 [----------------------------------] 100%
Optional dependencies for python-lxml
    python-beautifulsoup4: support for beautifulsoup parser to parse not well formed HTML
    python-cssselect: support for cssselect
    python-html5lib: support for html5lib parser
    python-lxml-docs: offline docs
( 6/19) installing python-pygments                             [----------------------------------] 100%
( 7/19) installing python-anytree                              [----------------------------------] 100%
( 8/19) installing gtk-doc                                     [----------------------------------] 100%
Optional dependencies for gtk-doc
    dblatex: PDF support
( 9/19) installing netpbm                                      [----------------------------------] 100%
(10/19) installing gts                                         [----------------------------------] 100%
(11/19) installing graphviz                                    [----------------------------------] 100%
Optional dependencies for graphviz
    mono: sharp bindings
    guile: guile bindings [installed]
    lua: lua bindings [installed]
    ocaml: ocaml bindings
    perl: perl bindings [installed]
    python: python bindings [installed]
    python2: python2 bindings [installed]
    r: r bindings
    tcl: tcl bindings [installed]
    qt5-base: gvedit [installed]
    gtk2: gtk output plugin [installed]
    xterm: vimdot
(12/19) installing vala                                        [----------------------------------] 100%
(13/19) installing ninja                                       [----------------------------------] 100%
(14/19) installing meson                                       [----------------------------------] 100%
(15/19) installing python-markupsafe                           [----------------------------------] 100%
(16/19) installing python-beaker                               [----------------------------------] 100%
(17/19) installing python-mako                                 [----------------------------------] 100%
(18/19) installing python-markdown                             [----------------------------------] 100%
(19/19) installing gobject-introspection                       [----------------------------------] 100%
:: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Warn about old perl modules
==> Making package: pamac-aur-git 9.4.0.r11.ga49fca5-2 (vie 03 abr 2020 15:19:32)
==> Retrieving sources...
  -> Cloning pamac git repo...
Clonando en un repositorio vacío '/home/keos/.cache/yay/pamac-aur-git/pamac'...
remote: Enumerating objects: 335, done.
remote: Counting objects: 100% (335/335), done.
remote: Compressing objects: 100% (219/219), done.
remote: Total 12559 (delta 242), reused 174 (delta 111), pack-reused 12224
Recibiendo objetos: 100% (12559/12559), 10.28 MiB | 618.00 KiB/s, listo.
Resolviendo deltas: 100% (10356/10356), listo.
==> Validating source files with sha256sums...
    pamac ... Skipped
itstool not satisfied, flushing install queue
==> Making package: pamac-aur-git 9.4.0.r11.ga49fca5-2 (vie 03 abr 2020 15:19:55)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating pamac git repo...
Extrayendo origin
==> Validating source files with sha256sums...
    pamac ... Skipped
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of pamac git repo...
Clonando en 'pamac'...
hecho.
==> Starting prepare()...
==> Starting pkgver()...
==> Sources are ready.
==> Making package: pamac-aur-git 9.4.0.r11.ga49fca5-2 (vie 03 abr 2020 15:20:04)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting pkgver()...
==> Starting build()...
The Meson build system
Version: 0.54.0
Source dir: /home/keos/.cache/yay/pamac-aur-git/src/pamac
Build dir: /home/keos/.cache/yay/pamac-aur-git/src/pamac/builddir
Build type: native build
Project name: pamac
Project version: 9.0
Using 'CFLAGS' from environment with value: '-march=x86-64 -mtune=generic -O2 -pipe -fno-plt'
Using 'LDFLAGS' from environment with value: '-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now'
Using 'CPPFLAGS' from environment with value: '-D_FORTIFY_SOURCE=2'
Using 'CFLAGS' from environment with value: '-march=x86-64 -mtune=generic -O2 -pipe -fno-plt'
Using 'LDFLAGS' from environment with value: '-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now'
Using 'CPPFLAGS' from environment with value: '-D_FORTIFY_SOURCE=2'
C compiler for the host machine: cc (gcc 9.3.0 "cc (Arch Linux 9.3.0-1) 9.3.0")
C linker for the host machine: cc ld.bfd 2.34
Vala compiler for the host machine: valac (valac 0.48.2)
Host machine cpu family: x86_64
Host machine cpu: x86_64
Found pkg-config: /usr/bin/pkg-config (1.6.3)
Found pkg-config: /usr/bin/pkg-config (1.6.3)
Run-time dependency gobject-2.0 found: YES 2.64.1
Run-time dependency gio-2.0 found: YES 2.64.1
Run-time dependency gthread-2.0 found: YES 2.64.1
Run-time dependency libalpm found: YES 12.0.1
Run-time dependency json-glib-1.0 found: YES 1.4.4
Run-time dependency libsoup-2.4 found: YES 2.70.0
Run-time dependency polkit-gobject-1 found: YES 0.116
Run-time dependency libnotify found: YES 0.7.9
Run-time dependency appstream-glib found: YES 0.7.17
Run-time dependency gtk+-3.0 found: YES 3.24.14
Run-time dependency gdk-3.0 found: YES 3.24.14
Run-time dependency gdk-pixbuf-2.0 found: YES 2.40.0
Library posix found: YES
Library m found: YES
Program g-ir-compiler found: YES (/usr/bin/g-ir-compiler)
Run-time dependency appindicator3-0.1 found: YES 12.10.0
Configuring org.manjaro.pamac.manager.service using configuration
Configuring org.manjaro.pamac.daemon.service using configuration
Program pacman-mirrors found: NO
Build targets in project: 20

Found ninja-1.10.0 at /usr/bin/ninja
[7/75] Compiling Vala source ../src/alpm_config.vala ../src/dependency_checker.vala
../src/alpm_config.vala:350.2-350.18: warning: method `AlpmConfig.write' never used
	public void write (HashTable<string,Variant> new_conf) {
	^^^^^^^^^^^^^^^^^
Compilation succeeded - 1 warning(s)
[10/75] Compiling Vala source ../src/version.vala ...../src/pamac_config_daemon.vala ../src/daemon.vala
../src/alpm_package.vala:51.3-51.26: warning: method `Pamac.AlpmPackage.dup' never used
		internal AlpmPackage dup () {
		^^^^^^^^^^^^^^^^^^^^^^^^
../src/alpm_utils.vala:886.3-886.33: warning: method `Pamac.AlpmUtils.trans_check_prepare' never used
		public bool trans_check_prepare (bool sysupgrade,
		^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Compilation succeeded - 2 warning(s)
[13/75] Compiling Vala source ../src/package.vala ...tion_interface_daemon.vala ../src/transaction.vala
../src/alpm_config.vala:350.2-350.18: warning: method `AlpmConfig.write' never used
	public void write (HashTable<string,Variant> new_conf) {
	^^^^^^^^^^^^^^^^^
../src/database.vala:2442.1-2442.27: warning: method `pkg_search_name' never used
private int pkg_search_name (Pamac.Package pkg, string name) {
^^^^^^^^^^^^^^^^^^^^^^^^^^^
../src/alpm_utils.vala:677.3-677.28: warning: method `Pamac.AlpmUtils.download_pkg' never used
		public string download_pkg (string sender, string url) {
		^^^^^^^^^^^^^^^^^^^^^^^^^^
Compilation succeeded - 3 warning(s)
[33/75] Compiling Vala source ../src/tray.vala ../src/tray-gtk.vala src/pamac.vapi
../src/tray-gtk.vala:26.22-26.35: warning: Gtk.StatusIcon has been deprecated since 3.14
Compilation succeeded - 1 warning(s)
[75/75] Linking target src/pamac-manager
==> Entering fakeroot environment...
==> Starting package_pamac-aur-git()...
[0/1] Installing files.
Installing subdir /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/gnome-shell/pamac-updates@manjaro.org to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/gnome-shell/extensions/pamac-updates@manjaro.org
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/gnome-shell/pamac-updates@manjaro.org/stylesheet.css to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/gnome-shell/extensions/pamac-updates@manjaro.org
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/gnome-shell/pamac-updates@manjaro.org/metadata.json to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/gnome-shell/extensions/pamac-updates@manjaro.org
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/gnome-shell/pamac-updates@manjaro.org/README.md to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/gnome-shell/extensions/pamac-updates@manjaro.org
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/gnome-shell/pamac-updates@manjaro.org/extension.js to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/gnome-shell/extensions/pamac-updates@manjaro.org
Installing subdir /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/icons/hicolor to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/icons/hicolor
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/icons/hicolor/48x48/apps/system-software-install.svg to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/icons/hicolor/48x48/apps
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/icons/hicolor/32x32/apps/system-software-install.svg to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/icons/hicolor/32x32/apps
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/icons/hicolor/scalable/status/pamac-tray-update.svg to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/icons/hicolor/scalable/status
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/icons/hicolor/scalable/status/pamac-tray-no-update.svg to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/icons/hicolor/scalable/status
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/icons/hicolor/16x16/apps/system-software-install.svg to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/icons/hicolor/16x16/apps
Installing src/libpamac.so to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/lib
Installing src/pamac.h to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/include
Installing src/pamac.vapi to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/vala/vapi
Installing src/Pamac-9.0.gir to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/gir-1.0
Installing src/Pamac-9.0.typelib to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/lib/girepository-1.0
Installing src/pamac-daemon to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/bin
Installing src/pamac to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/bin
Installing src/pamac-tray to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/bin
Installing src/pamac-tray-appindicator to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/bin
Installing src/libpamac-gtk.so to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/lib
Installing src/pamac-gtk.h to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/include
Installing src/pamac-gtk.vapi to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/vala/vapi
Installing src/pamac-manager to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/bin
Installing src/pamac-installer to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/bin
Installing src/dependency-checker to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/bin
Installing data/polkit/org.manjaro.pamac.policy to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/polkit-1/actions
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/builddir/meson-private/pamac.pc to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/lib/pkgconfig
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/applications/pamac-installer.desktop to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/applications
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/applications/pamac-updater.desktop to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/applications
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/applications/pamac-manager.desktop to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/applications
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/applications/org.manjaro.pamac.manager.desktop to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/applications
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/applications/pamac-tray.desktop to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/etc/xdg/autostart
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/applications/pamac-tray-budgie.desktop to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/etc/xdg/autostart
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/applications/pamac-tray-appindicator.desktop to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/etc/xdg/autostart
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/config/pamac.conf to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/etc
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/builddir/data/dbus/org.manjaro.pamac.manager.service to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/dbus-1/services
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/builddir/data/dbus/org.manjaro.pamac.daemon.service to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/dbus-1/system-services
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/dbus/org.manjaro.pamac.daemon.conf to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/etc/dbus-1/system.d
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/gnome-shell/org.manjaro.pamac.manager.search-provider.ini to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/gnome-shell/search-providers
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/mime/x-alpm-package.xml to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/mime/packages
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/systemd/pamac-daemon.service to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/lib/systemd/system
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/systemd/pamac-cleancache.service to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/lib/systemd/system
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/data/systemd/pamac-cleancache.timer to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/lib/systemd/system
Running custom install script '/usr/bin/meson --internal gettext install --subdir=po --localedir=share/locale --pkgname=pamac'
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/builddir/po/af.gmo to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/locale/af/LC_MESSAGES/pamac.mo
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/builddir/po/ar.gmo to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/locale/ar/LC_MESSAGES/pamac.mo
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/builddir/po/ast.gmo to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/locale/ast/LC_MESSAGES/pamac.mo
Installing /home/keos/.cache/yay/pamac-aur-git/src/pamac/builddir/po/az_AZ.gmo to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/locale/az_AZ /pamac/builddir/po/zh_TW.gmo to /home/keos/.cache/yay/pamac-aur-git/pkg/pamac-aur-git/usr/share/locale/zh_TW/LC_MESSAGES/pamac.mo
==> Tidying install...
  -> Removing empty directories...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "pamac-aur-git"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Adding install file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Starting package_pamac-aur-tray-appindicator-git()...
==> Tidying install...
  -> Removing empty directories...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "pamac-aur-tray-appindicator-git"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: pamac-aur-git 9.4.0.r11.ga49fca5-2 (vie 03 abr 2020 15:20:20)
==> Cleaning up...
==> Found git repo: gitlab.manjaro.org/applications/pamac.git
loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (1) pamac-aur-git-9.4.0.r11.ga49fca5-2

Total Installed Size:  2.64 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                                 [----------------------------------] 100%
(1/1) checking package integrity                               [----------------------------------] 100%
(1/1) loading package files                                    [----------------------------------] 100%
(1/1) checking for file conflicts                              [----------------------------------] 100%
:: Processing package changes...
(1/1) upgrading pamac-aur-git                                  [----------------------------------] 100%
:: Running post-transaction hooks...
(1/6) Reloading system manager configuration...
(2/6) Arming ConditionNeedsUpdate...
(3/6) Reloading system bus configuration...
(4/6) Updating icon theme caches...
(5/6) Updating the desktop file MIME type cache...
(6/6) Updating the MIME type database...
[keos@keos-pc ~]$ 


Lo tuve que cortar, es demasiado grande … ¿Estará todo bien?. Quien sabe … solo sé que di enter!!

Everything will be ok.

Muchas gracias Halcek, pero … ¿será siempre ese el método correcto? ‘enter’, ‘enter’, ‘enter’ …?

Sigo sin entender,

Saludos!

Yes, that is the normal, standard update process:

  1. Open up the Terminal, or Konsole, and type in sudo pacman -Syyu:

sudo means that you want to administer the computer, you need to be an administrator (called super user) when doing a system update.

pacman is the package manager of Arch LInux/Endeavour OS, you need a package manager to update packages (software) in linux.

When you are the administrator, and you have opened the package manager pacman, then you need to let pacman know what action, what operation you want it to do.
-Syyuu tells pacman to synchronise, i.e. update its databae of available software, and then update the software on your computer to the latest versions it has available.

Then pressing y means yes, confirming that you want to do an update.
And then just pressing Enter means continue

Until the update is complete:

You can do this every week to always get the newest system updates.

It’ not pamac, but yay who asks you questions. You can tell it to stop it and just do it’s job :upside_down_face:

yay --nocleanmenu --nodiffmenu --noeditmenu --noupgrademenu --removemake --useask --combinedupgrade --save

A config.json file will be generated in your ~/.config/yay/ directory with the options. If you want to revert to defaults just remove it.

/* Please, let me know if any of the options I wrote are not recommended to use */

1 Like

@Halcek Gracias por tan extensa respuesta pero lamentablemete sigo sin comprender … debo ser muy burro pero a mi juicio esto que sigue abajo, que es lo que planteo desde el primer ‘post’, NO TIENE NINGUNA LÓGICA:

1  aur/pamac-aur-git  9.4.0.r9.gc2ffcd0-1 -> 9.4.0.r11.ga49fca5-2
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
==> 

@Tasia91 Muchas gracias , creo que esto si nadie pone alguna objeción a tus comandos es lo mejor que podría hacer. De hecho creo que es algo que el sistema debería incluir para evitar tan engorroso cuestionamiento, sí, en este caso es yay pero pacman tambien lo hace … por eso modifiqué el título del asunto.

¿No hay objeciones a este procedimiento?

1 Like

It is unnecessary, and it confuses new users. If you had more updates, they would be numbered like:

  1. software a
  2. software b

So the logic is that if you want to only update software a, but do not want to update software b, you would press 2 there, as exclude means ignore the update for software b, which is under number 2 in our scenario.

Pressing ENTER means that you want to update everything at once, without excluding any package from the update.

You just have to get used to how it works, even if it’s not all that logical :slight_smile:

1 Like

¿No sería mejor entonces hacer lo que sugiere Tasia?. Pedirle al sistema que haga lo que tiene que hacer me separa a mi de la posibilidad de cometer un error, ¿no crees que eso sería lo mejor?. Claro que aún no se si algunos de esos comandos deben hacerse siempre que vengan esas preguntas – digamos entonces no mas’ ilógicas’ … llamémosles ‘incomprensibles’, ¡viva la retórica! – o si de una vez resuelven el asunto. Y a veces con pacman sucede igual, te quedas que no sabes que hacer, en fin, solo planteo el caso de esta preocupación desde mi perspectiva como usuario que no tiene dominio del sistema y teme que una imprdudencia lo puede llevar todo al colapso – la confusión ya existe!.

Saludos!

Sure, you can do what Tasia says. Do not be afraid of updating via the terminal. If a package is broken, it will usually not get updated, and the process will stop, to keep your system functional.

Gracias, de cualquier manera, he instalado octopi y hoy vino una actualización y observé que después de esas extrañas preguntas (aparecen también durante la descarga abajo) se detenía un momento y continuaba después haciendo su trabajo … ¡sin molestarme para nada con preguntas!.

¡Viva Octopi!