Duplicate grub entries appearing

I just installed EOS XFCE on a new partition (sda5). I noticed on the grub boot menu it had a duplicate entry of my EOS gnome partition

I thought no problem, I’ll just set the gnome bootloader to load first, then reinstall grub so it adds the XFCE parttion to the list. I’ve done this many times in the past with no problems. I’ve also installed EOS many times on various partitions without ever getting duplicate grub entries

Well, this happened…

None of these extra entries show up in the bios or efi folder. How do I delete them? Funny thing is all of them work fine

try the command:

grub-mkconfig -o /boot/grub/grub.cfg


https://wiki.archlinux.org/title/GRUB

I tried that and it didn’t work

Probably one of these obscure distros I’ve been testing screwed up my efi partition. Grub just spawns duplicates now when I install something new

please post the output/URL from the following commands:

efibootmgr

cat /boot/grub/grub.cfg | eos-sendlog

cat /etc/default/grub | eos-sendlog

Edit:

yay -Qs grub

Do you have grub-customizer installed? It could be the root of the problem.

1 Like

If they do this thread is as good as closed :hugs:

Definitely looks that way…

No grub customizer

Anyways I wiped the hard drive. Problem solved, now it’s nice and tidy with only one entry

1 Like

Another reason might have been (history now) that you installed Grub on different partitions at the same time.

For example on /dev/sda - and on /dev/sdaX at the same time, unknowingly. Configuring Grub to save rescue-entries then can contribute to the mess-up.

Otherwise, this would be hard to explain…