Dual Boot Windows + EOS Installation failed error

Hello, I’m trying to install EOS alongside Windows on my ThinkPad X1. I’ve previously installed both, but after not using EOS in a while, I was unable to log into EOS as it would boot directly into Windows. BIOS options did not let me choose EndeavourOS.

Anyways, I reformatted the entire EOS partition and went on to reinstall with the new installer- using “Install alongside” and at the end of the installation I get the following error:

Installation Failed
Boost.Python error in job “bootloader”.
Command ‘grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS --force’ returned non-zero exit status 1.
Installing for x86_64-efi platform. grub-install: error: cannot open ‘/boot/EFI/EndeavourOS/grubx64.efi’: No such file or directory.

I remember something about os-prober from the old Installation page, however I can’t find that article on the EOS site anymore.

Help would be appreciated!

1 Like

My suggestion would be to do a manual partition and manually assign mount points in the installer without re-formatting anything since you have already done that.

The error indicates it fails to place the boot loader in the correct partition, which unfortunately is a common bug in the installer if you use the automatic partition option.

edit: The key point here is to assign the already formatted (by Windows) Windows bootloader partition to /boot/efi to ensure the installer puts GRUB in the right “spot” and then assign the EOS partition you made and formatted to /


alongside will use the ESP from Windows and try adding entry for EndeavourOS, it could be that it fails to get write permission zo this partition or it does not have enough space to add an entry.
So yes use manual partition and create a new ESP efi fat32 partition to be used by Eos would do the trick.


This is what I currently have it set as, with /dev/nvme0n1p1 (Windows bootloader) as /boot/efi and /dev/nvme0n1p4 as root partition. Still get the same error

Trying this now, thanks.

I can see there are only 100MB for the ESP from windows, the recommandation is 215MB as minimum.
Would be interesting to see the output of:
lsblk -f
will show percentage used of the partitions.

I just followed your previous suggestion and it worked!!

Resized the partition and made a new fat32 with 570mb. Set as /boot/efi and installation went smooth, boots just fine into both Windows and EOS.

Maybe the size limitation with the Windows ESP had something to do with the errors.


lsblk -f would show if it is already full, if not that it could be also permission issue or something causing that installer could not write to the partition, i like it also more to separate windows and linux in dual boots, because windows can screw the entries also on updates.


@BONK thanks for fixing my “too fat fingers typos” :crazy_face:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.