Dual Boot - Windows Booteintrag in Grub fehlt

Vielleicht könnt ihr mein letztes Problöem auch noch lösen.
Ich habe im rechner eine 2. ssd auf der Windows 11 installiert ist.
Leider wurde bei der Installation von Endeavours kein Bootmenü eintrag erzeugt.
update-grub wird nicht gefunden. Was kann ich tun?
VG
Michel

Ich verstehe es nicht.

sudo fdisk -l
Festplatte /dev/sda: 931,51 GiB, 1000204886016 Bytes, 1953525168 Sektoren
Festplattenmodell: Samsung SSD 850 
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
Festplattenbezeichnungstyp: gpt
Festplattenbezeichner: E4C1B446-D53B-0C43-96B8-9510BBDAE65D

Gerät          Anfang       Ende   Sektoren  Größe Typ
/dev/sda1        4096     618495     614400   300M EFI-System
/dev/sda2      618496 1881490092 1880871597 896,9G Linux-Dateisystem
/dev/sda3  1881490093 1953520064   72029972  34,3G Linux Swap


Festplatte /dev/sdb: 931,51 GiB, 1000204886016 Bytes, 1953525168 Sektoren
Festplattenmodell: CT1000MX500SSD4 
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 4096 Bytes
E/A-Größe (minimal/optimal): 4096 Bytes / 4096 Bytes
Festplattenbezeichnungstyp: gpt
Festplattenbezeichner: 964ACA44-9F8F-4FB8-8304-59F22A986A4F

Gerät          Anfang       Ende   Sektoren  Größe Typ
/dev/sdb1        2048      34815      32768    16M Microsoft reserviert
/dev/sdb2       34816 1952166464 1952131649 930,8G Microsoft Basisdaten
/dev/sdb3  1952167936 1953519615    1351680   660M Windows-Wiederherstellungsumgebung

Auf sdb liegt meine Windows Installation.

[michel@michel-nuc7i7dnhe ~]$ sudo os-prober
[michel@michel-nuc7i7dnhe ~]$ sudo grub-mkconfig -o /boot/grub/grub.cfg
GRUB-Konfigurationsdatei wird erstellt …
Thema gefunden: /boot/grub/themes/EndeavourOS/theme.txt
Linux-Abbild gefunden: /boot/vmlinuz-linux
initrd-Abbild gefunden: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-fallback.img
Warnung: Zur Erkennung anderer bootfähiger Partitionen wird os-prober ausgeführt.
Dessen Ausgabe wird zur Erkennung bootfähiger Programmdateien und Erzeugen neuer Boot-Einträge verwendet.
Bootmenü-Eintrag für UEFI-Firmware-Einstellungen wird hinzugefügt …
abgeschlossen

Sie wird aber nicht gefunden

Kannst Du ein büschn Englisch?

Benutze bitte die im Post-Editor vorgegebenen Möglichkeiten zur Formatierung Deiner eingefügten Postings!
</> für code, ‘’ für Zitate, usw.

Damit wird das Ganze wesentlich lesbarer u. auch für die hier eingebaute Suchfunktion auffindbar.

Das alles ist auch nachträglich noch möglich.

Danke.

Was sagt der Befehl
lsblk -f ?
Kannst Du das hier posten? (Als code formatiert “</>”?

Andererseits bist Du alles andere als allein mit dem Problem:

Es gibt eine Lösung! - Also…

1 Like

Danke für die Antwort. Ich gehe nochmal zurück auf Null. Habe per Clonezilla mein Debian wieder zurück gespielt. Alles Booteinträge in Grub sind wieder da.
Jetzt will ich EOS erneut installieren. Gibt es was zu beachten, damit nachher beide Betriebssysteme sauber im Grub Menü stehen?
VG
Michel

ja ich kann auch ein bisschen Englisch und dein Hinweis kommt zu Recht. War schon spät gestern Abend. Ich gelobe Besserung

aber ichs ehe keine ESP efi partition auf der Windows Platte… könnte sein es ist im CSM (legacy) Modus installiert?

hätte soetwas erwartet:
2022-08-25_09-10
Nichts desto trotz kann sein das es so ist und du deshalb einen Eintrag für Windows manuell erzeugen musst damit grub denb bereit stellen kann.

/etc/grub.d/40_custom:

#! /bin/sh -e
echo "Füge einen Starteintrag für Windows ein" >&2
cat << EOF
menuentry "Microsoft Windows im BIOS-Modus starten" {
        insmod part_gpt
	insmod ntfs
	search --no-floppy --fs-uuid --set=root *hier uuid von /dev/sdb hin*
        parttool \${root} hidden-
	drivemap -s (hd0) \${root}
	chainloader +1
}
EOF

UUID: sudo blkid /dev/sdb2

könnte auch sein das hd0 mit hd1 ersetzt werden muss damit es sdb nutzt…

Danach nochmals versuchen die grub.cfg neu zu erstellen um zu sehen ob der Eintrag erkannt und zugefügt wird…

ok. Ich installiere später EOS neu. Wenn dann kein Windows zu sehen ist, werde ich deine Anleitung testen.
Danke!