Dual boot no longer appearing after updating

I had an old install of Endeavour (probably 1-2 years) dual booted on my Windows PC that I hadn’t touched in a while. Tried booting it up recently, and had some issues with pacman/mirrors, and ended up updating it (using yay, I believe). After updating, I restarted my computer and no longer see an option to boot into Endeavor OS.

In particular, when I try to open the boot menu by clicking F1 while booting, it brings me to the “Windows Boot Manager.” Previously, if I clicked escape, it’d previously show me options to boot endeavour OS, but now it just briefly flashes “Welcome to GRUB!” goes black momentarily, flashes a cursor at the top left a single time, and then opens the MSI Click BIOS 5 menu. Closing this window then automatically launches Windows.

Another menu I’ve been able to bring up (which I believe has worked for me in the past) is by pressing F11, which opens the “Please select boot device:” with five options, one of which being "Windows Boot Manager (SATA2: Samsung SSD B60 EVO 500GB) and another "endeavouros-5211 (SATA2L Samsung SSD 860 EVO 500GB). Selecting the EndeavourOS option in this case results in basically the same sequence of events as through the other menu.

I’m not quite sure what the issue is that caused this, but I’m assuming it’s something to do with the update. I’ve seen online some suggested fixes, but they all seem to require using a terminal, which I’m not sure how I’d be able to access in the first place.