Dual boot - direct boot into Windows


Don’t say tltr!

My problem: After instaling EndeavourOS laptop boots directly into Windows 10 Pro. No GRUB menu. I cannot start EndeavourOS Atlantis Neo.

  • I have flagged partitions: efi with boot, / with root, swap with swap

My system:

  • XMG Neo 15 (2020), Win10 Pro, UEFI, Nvidia RTX 2070 Refresh
  • 1TB Samsung 970 Evo Plus nvme SSD (EndeavourOS installed; P1: efi partition 500MB, P2: root, P3 home), before, First Manjaro was installed. Then I installed endeavouros, same error like now, then I installed again endeavouros.
  • 1TB Seagate FireCuda 520 nvme SSD (OS: Windows 10 Pro, EFI partition, …)

I had created a usb flash boot media via Rufus, i guess I chosed GPT. And I guess it was ISO Mode (How to check?).

I created a GPT partition table when installing EndeavourOS.

I tried to follow these, no success:

The Bootloader of Endeavouros is not shown in UEFI boot menu.
Secure boot, fast boot, hibernation are disabled.
After my first installation of Endeavouros I tried to boot in Legacy Mode (not UEFI), did not work.

remark: I guess the Calamares installer does not recognize everything you create with Gparted. It does not seem to be consistent. I had read this also.

commands I used during Endeavouros Live:
https://ibb.co/MB370kz (efibootmgr)
https://ibb.co/JQK4QgB (fdisk -l)
https://ibb.co/ynW8wbF (lsblk -fml)

This is very strange for me, it says that the bootloader of EndeavourOS is on partition 2, but fdisk -l says that it is on partition 1, as I created it.
https://ibb.co/BySnqJD (os-prober)

Any help is appreciated.

Ok, i have found my mistake and solved. In UEFI settings menu UEFI Nvme Drive BBS Properties I had to chose the Boot option order, where endeavouros-6148 loader is listed. Then you can do the boot order change in the previous menu in UEFI settings.

But this interests me, still, why is that so?

Can we see the output of:

lsblk -o name,type,fstype,size,mountpoint

Hi, the output is:
https://ibb.co/YdR8RqB (I have done this on my installed EndeavourOS Atlantis Neo now).

Partition 1 is your efi partition but your kernel and initramfs are on partition 2.

Is that bad? (sorry, just a noob)

No, that is normal.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.