DNS Requests via IPv4 sometimes doesnt work

Try changing “stable” to “permanent”. See this article: https://blogs.gnome.org/thaller/2016/08/26/mac-address-spoofing-in-networkmanager-1-4-0/

“permanent”: use the permanent MAC address of the device. Before 1.4.0, the permanent MAC address was used if the “cloned-mac-address” property was left empty, thus it was the default.

ill take a look at this when i get home and try this out, thanks… (arch wiki didn’t mention a permanent so i didn’t think the option existed)

If you connected both via WiFi and Wired, then your PC has one IP for WiFi interface and one IP for wired Ethernet. Which is normal.

REFUSED means that your PC which has some remote IP for DNS server, contacted it succesfully.
But that remote machine either don’t actually have DNS server, or it’s 53/udp + 53/tcp port blocked for your PC (or everybody), or DNS server not turned on.

Also REFUSED can happen if routers firewall rules are made to do so, which is 99% not a case here.


I see virbr1 (virtual bridged connection 1) which probably bridges WiFi and Wired under one interface. Does it work if you don’t use virbr1 and connect Wired directly? I mean delete virtual bridge entirely and connect wired ethernet connection.

Maybe somethings up with having WiFi interface as part of virtual bridge.

nah, virbr1 is for virtual machines and it only bridges the ethernet so i can bridge my vm’s directly to the network. I never use Wi-Fi on the system, and only used it once to test if it was the system or the adapter, and disabled my ethernet adapter when i had Wi-Fi connected for testing, and it gave the same result.

i haven’t had an issue since changing it and wiping my network configs… im just going to say this is the fix

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.