Distrohopping cure

like probably many others, once i dappled into linux i stumbled upon the distrohopping drug.
however, endeavouros has cured this addicition since last year, somethign im mroe proud of than i very much should be.

dumpe2fs 1.46.2 (28-Feb-2021)
Filesystem created:       Sat Dec 26 19:03:29 2020
15 Likes

Welcome - I guess you’ll find that a common theme here… :slight_smile: Many of the users end their distro hopping with Endeavour…

Same story with me - long time Ubuntu user - started distro hopping badly about 2 months back (Virtualbox VM got messed up - some compatibility issue with post 5.4 kernels)… Started exploring - almost settled with Manjaro - then realized that Teams had a problem with screen sharing (with the GNOME compositor) - so started looking for a more minimal distro - settled with Endeavour, XFCE…

This is where I’ve got to…

[A big big thanks to the entire Endeavour team for their brilliant work - I absolutely believe that there is a very clear role that Endeavour fulfills in the role of Linux on the desktop today - so pls pls keep this up, team…]

15 Likes

xfce is probably my second most used DE in all of this, tho sooner or later i jumped back to my most used one, being cinnamon, which i stuck with in this install.

3 Likes

I believe one reason for that is the devs concern for the user experience. When ever there is discussion on how to do this or should we do that, in the end how it effects the user experience is always a factor. The devs do what’s best for the users, not what is easiest for the devs.

Pudge

8 Likes

Nice!

1 Like

True. It does show in the end result…

That desktop looks great! Can I ask what widget or whatever you have there that shows all those usage statistics? I’ve got a temp sensor thing, but I really like the look of yours!

1 Like

Hi, thats conky - if you are familiar with it… (https://github.com/brndnmtthws/conky/wiki)

I have the dials scripts ready to upload, but the forum allows me to only upload images… (the zip has a lua script and a .conf file)…

I was anyway planning to post the entire theme/rice on reddit’s /unixporn group - will post a link to that post and/or the Github pages by today/tomorrow here (that should get you the dials)?

1 Like

After a while, one gets to the point where one does not bounce between distributions but uses one for everyday purposes.

2 Likes

True, there was a point where I was asking myself ‘what am I doing in life?’ :slight_smile: [burnt out a USB drive with the number of formats I had to do - distro+DE combinations]… So I went by freezing the core first (this became Arch) → then DE with options to add others if needed (which meant minimal, customizable distro) → result = Endeavour… Anyway…

3 Likes

Hi, finally got to uploading the scripts to Github - URL given below:

Pls try it out and let me know if you run into trouble. Thanks.

[Amanda, didnt mean to hijack your original post… My apologies…]

2 Likes

Just got a new Lenovo IdeaPad for my birthday. It’s 14”, Ryzen 5, 8GB RAM, 256GB SSD. It’s one notch above a Chromebook, but adequate for my needs. It came with W10 “Home” but of course that won’t do. I promptly installed Mint Cinnamon alongside Windows but it booted to a blank screen. Hmmm. Display stuff.

I switched to Mint xfce but the installer crashed. Said some of the files failed to install properly. Hmmm again. No problem. I re-positioned to Zorin ”Lite” (xfce). This seemed to work fine except that it kept complaining about broken packages. I tried fixing them and then I tried removing them but the message wouldn’t clear. How odd.

Next up was Linux Lite. This also installed without drama and seemed to be working well. Then it refused to boot. Apparently the first update broke it. I could boot it in compatibility mode but found nothing wrong with it. Seriously—there was nothing to troubleshoot. How annoying.

Finally I did what I should’ve done the first time. I installed EndeavourOS with both Cinnamon & xfce (just to cover my bases) DEs. So far EOS has been effortless. Cinnamon and xfce both work perfectly. No weird error messages. No mysterious broken packages. No blank screens. And no PPAs! Everything I need is available from the official repos and/or the AUR.

I know I’m repeating myself but why do people think arch-based distros are weird & edgy? I could’ve saved myself hours of frustration by installing EOS first. EOS is easy. EOS is for noobs.

8 Likes

Arch is suited to new hardware as their kernels, firmware and drivers are always the latest. Maybe that is why you had issues with other LTS distros built on an older package base.

Edgy because Arch is a rolling distro in a constant state of change.

Bleeding Edgy because Arch is the first distro to get package updates, usually within a day or two of upstream release, so Arch users are the first to experience any issues and are expected to report bugs upstream for patching.

Weird because the Arch Way preaches technical proficiency and self sufficiency in equal abundance, hence the creation of the incredibly detailed Arch Wiki. Arch is not idiot proof, idiots don’t like that.

The EOS installer is easy, but managing the resulting rolling Arch system going forward is definitely not for noobs.

1 Like

Gobble Gobble

3 Likes

What Ubuntu is to Debian, EOS is to Arch.
There has to be a certain level of seriousness in being a derivative of a linux distro based on a shaky plane. Not saying Arch is weak but rather the corporate environments that Fedora and Ubuntu have the backup of. EOS comes closest without being too geeky or toyish.

3 Likes

Huh? Cicking on the RED thingamajig whenever it appears is not for n00bs? What could be easier?

2 Likes

The same was orignally said about Manjaro, and I guess the analogy fits Manjaro much better coz it’s more curated and “made easy” and complete as an OS.

Manjaro from the beginning had its own thing going for it…they had their own tools for installing drivers and other stuff. All this resulted in bloating it up more and more. Today its too bulky.
EOS, if I’m right sticks to the Arch core and drivers that are easy with dkms will always be preferred. Source and its dependencies are no longer a problem.

1 Like

EOS is Arch with an installer. The installed system is Arch.

5 Likes

Exactly! Manjaro has it’s own thing going, overcomplicates everything and is a bloated mess.

  • EXACTLY * LIKE * UBUNTU! *
2 Likes