Display keeps turning off

I have edited both lightdm.conf and 10-eos-slick.conf and added

xserver-command=X -s 0 -dpms

i have also edited my ~/.xinitrc file and added

setterm -powersave off -powerdown 0

xset -dpms s off s noblank s noexpose

And i uninstalled xscreensaver, xfce4-screensaver, and disabled power manager and yet still my display turns off after 5 minutes or so

What desktop environment are you using? Have you searched for sleep settings in the settings application of that DE?

I am using xfce and there are no sleep settings but there is power manager which i disabled

Is there an option like “Screensaver” on Settings Manager? Maybe something like this:

Try turning off Screensaver and Lock Screen.

1 Like

there used to be but i removed xscreensaver and xfce4-screensaver, I seem to have fixed it, and for anyone with the same issue what i did was i edited the lightdm slick config and added ‘-dpms s off s noblank s noexpose’ so it looked like this

/etc/lightdm/lightdm.conf.d/10-eos-slick.conf
Seat:*]
xserver-command=X -dpms s off s noblank s noexpose
greeter-session=lightdm-gtk-greeter
allow-user-switching=true

and then i also edited my xinitrc file

/etc/X11/xinit/xinitrc 

or

~/.xinitrc

and i added this to the end of the file

setterm -powersave off -powerdown 0

xset s 0
xset s cycle 0
xset s noblank
xset s noexpose
xset s off

i also added consoleblank=0 to my boot paramaters and my display didnt turn off at all last night so one of those edits did it

1 Like

and before i uninstalled the xscreensaver and xfce4-screensaver i had already disabled power manager, lock screen, and screensaver

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.