Disabling keyboard on boot

Hello, recently my keyboard started to type “=” sign randomly. It’s hard for me to log in. I have to type my password really fast otherwise it gets filled with “=”.
I don’t want to replace it because i don’t even use it, i prefer usb keyboard. But i can’t find a way to disable it before login screen. I found a way to disable it after i log in tho, i use xinput command:
xinput float $(xinput list ‘AT Translated Set 2 keyboard’|grep id=|cut -f 2|cut -f 2 -d =)

I put it in /etc/profile.
Is there a way to make execute this command on boot, so i can login without any issues ? I’m willing to disable laptop keyboard permanently if anyone knows how to do it.
I use lightdm display manager, I already tried putting this command in:
And probably many others that i just don’t remember, since ideal with this keyboard for quite some time. Thanks to anyone answering :slight_smile:

Welcome! :smile:

Can you try another keyboard?
EDIT: on laptop it may be a problem. Maybe cleaning the keyboard from potential dust etc. could help?

You can try to add in your GRUB_CMDLINE_LINUX_DEFAULT line the i8042.nokbd boot parameter. Something like that: GRUB_CMDLINE_LINUX_DEFAULT=“quiet loglevel=3 i8042.nokbd”
I have done it in a deb-based distro.

i8042.nokbd [HW] Don’t check/create keyboard port

from here

You could also just physically disconnect it.

Solved my problem, somehow i couldn’t find it earlier.

It would be nice if you posted what exactly you have used (which file/path what content).
The link does not have a unique answer, and it’s always better to keep those solutions locally (in this forum). :person_shrugging:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.