Disable Scrollbar Fading

Hello,

I’m new to EndeavourOS, coming from Windows 7. I’m using the XFCE desktop.

Is it possible to change the desktop theme so that the scrollbars are always visible and the full width, as when the mouse is hovering over it? I’d like to disable the default fade and narrowing of the scrollbar if possible.

Thank you.

edit:
I installed it myself now and can’t find a way. If it’s really important to you there are other terminals out there - tons of alternatives

Hi @carey.

UPDATE: This happens with the Thunar file manager. I just tested it with a few different themes.

I normally don’t use Thunar, instead I use PCManFM, and the scrollbars never fade.

If you want to try it, install it from the terminal: sudo pacman -S pcmanfm

Welcome to EndeavourOS. :smile:

1 Like

Thanks for the reply Keith. Unless I misunderstand, both your answer and @penguin007 seem to imply I’m only concerned about the fading scroll bars in one app, either Terminal or Thundar. But on the default desktop theme (Arc-Darker) of the EndeavourOS install I recently downloaded, all the apps have the fading scrollbars, not just Terminal and/or Thundar. So just replacing one or both of those apps doesn’t fix it for me.

But after I posted I continued to search for a solution, and apparently this “feature” I call fading scrollbars is called GTK Overlay Scrolling. And I found complaints like mine in other forums.

So what I found as a solution for me was to disable the fading by adding an environment variable to the file:
/etc/environment

GTK_OVERLAY_SCROLLING=0

And then I set a fixed width to the scroll bars by creating the CSS file:
/home/username/.config/gtk3.0/gtk.css

Added this CSS code and set my preferred pixel width:

scrollbar slider {
min-width: 15px;
}

Logged off and back in, and the annoying fading scrollbars are gone in all apps.

Thanks guys, for your replies and help.

3 Likes

nicely done.

Pls set your post as solved :wink:

@carey Well Done! I’m glad you were able to solve that problem.

Thanks for sharing the answer with us. :+1: