Different (same) package availably on different Endeavour builds

I run Cinnamon on both my DD and my son’s. I used to run it on my spare machine just because I would see common packages like a kernel update or GRUB change occurring before running ‘pacman -Syu’ on the DDs potentially averting time wasting disaster. Cinnamon was just too hard on the machine resources, so I starting messing with other Endeavour DTEs. Eventually, I settled on Budgie, and it is running GREAT. I have noticed that some of those common packages (DTE independent) are showing up about a day after they show up on the Cinnamon builds. Maybe I am missing something obvious. I know some packages may appear to be the same (like the 1/2 dozen varieties of Pamac) or might have DTE specific reasons or different maintainers, but the one that I am questioning currently (there have been others) is the LTS kernel (running current Arch build on all 3 machines and LTS as backup). It showed up on the Cinnamon machines last night, and as of a few hours ago is still not there for Budgie. My fail safe reason for installing to a backup machine is lost right now.

It is because you are using different mirrors. Each mirror updates on a different schedule. They should all get updated within a 24 hour window.


Perfect, and yes something obvious. LOL!

1 Like

Another trick you might make use of is one I use on my repo mirror setup. I don’t want it to go down because of an ‘iffy’ update - but I don’t want to run it on something else either. Instead I make use of the Archive maintained by Arch…

Essentially I only apply updates to the server once a week - and only up to a date one week prior to the date of the procedure. For instance, if the date is the 21st, I set eos-shifttime to the 14th on the server, and run the updates. This means I have had a week on other systems to determine is the updates ‘coming’ have any problems… and/or how to fix them if present.

While update-caused problems are amazingly rare, they ARE possible, and this is bypassing them reliably!

Yes, one of the mirrors is for EndeavourOS
1 Like

I’ll think about that. Thanks.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.