Desktop Settings issue

Does anyone else have to go to Desktop Settings twice before it works?


^ First right-click, Desktop settings, click, then it just sits like that.
Close that window, repeat, it works…

I didn’t have “desktop settings” but I right clicked for configure desktop and got this:


Everything appears normal. Are you on wayland or x11? It could be a compositor issue/glitch.

2 Likes

Tried wayland and x11…does it for both. I wondered if it’s because maybe I have too many wallpapers loaded, even for a i7-9750 with 32 gb ram and 2 TB ssd; so removed all of them, and it still does it.
And yeh, it’s “configure desktop and wallpaper”, which brings up Desktop Settings.
Thanks for checking!

NP. For reference, I’m X11 still ( can’t beat stability).

Screenshot_20210606_214238

1 Like

You, like I, have Desktop Folder Settings, as our layout is set to Folder View.
I’ll switch to Desktop View and see if it makes a difference, perhaps you could too, just to rule that out?

edit: No difference, it just works on my end, even after a reboot.
Sorry mate, stumped.

While I don’t have that issue, can you try turning off compositing (Display and Monitor - Compositor - Untick the box) and see if it still happens?

2 Likes

Turned the Compositor off, then turning it on again. Then it works. Sigh.

3 Likes

“It’s running Windows Vista! We’re all going to die!”

4 Likes

For this purpose I have a little script that resets the compositor on KDE Plasma:

#!/bin/sh
qdbus org.kde.KWin /Compositor suspend
qdbus org.kde.KWin /Compositor resume

Easier than navigating the settings, in my opinion.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.