Dependency errors when trying to update Endeavouros

I am getting the following dependency errors when trying to update. Any Ideas how to solve?


==> eos-update --aur
eos-update: package updater with additional features
Updating native and AUR apps...
[sudo] password for keith: 
:: Synchronising package databases...
 endeavouros is up to date
 core is up to date
 extra                                                                                                              7.9 MiB  12.8 MiB/s 00:01 [#######################################################################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing alsa-lib (1.2.12-1) breaks dependency 'alsa-lib=1.2.11' required by lib32-alsa-lib
:: installing alsa-plugins (1:1.2.12-1) breaks dependency 'alsa-plugins=1:1.2.7.1' required by lib32-alsa-plugins
:: installing nvidia-utils (550.90.07-2) breaks dependency 'nvidia-utils=550.78' required by lib32-nvidia-utils
:: installing pcre2 (10.44-1) breaks dependency 'pcre2=10.43' required by lib32-pcre2

I don’t use eos-update myself, but it looks like you are trying to tell it to only update aur packages without updating the system packages that they depend on. Arch does not support partial upgrades.

Edit: I was wrong.

Just looked up the info on eos-update and it seems isn’t the issue

--aur                 Uses the AUR helper configured in /etc/eos-script-lib-yad.conf

And when run

smokey@sycotikcystm-optiplex7050 ~ $eos-update --aur
eos-update: package updater with additional features
Updating native and AUR apps...

So it updates the system and AUR packages.

1 Like

Edit your /etc/pacman.conf and enable multilib repo.

[multilib]
Include = /etc/pacman.d/mirrorlist
2 Likes

Thanks, that fixed it.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.