Dépendance insoluble : YAY

I search but cant find solution :

: Synchronisation des bases de données de paquets…
endeavouros est à jour
core est à jour
extra est à jour
multilib est à jour
:: Début de la mise à jour complète du système…
résolution des dépendances…
avertissement : impossible de résoudre « pacman>6.1 », une dépendance de « yay »
:: Le paquet suivant ne peut être mis à jour à cause de dépendances insolubles :
yay
:: Voulez-vous ignorer le paquet ci-dessus pour cette mise à jour ? [o/N]
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: impossible de satisfaire la dépendance « pacman>6.1 » requise par yay

What is the solution ? (thanks :slight_smile: )

1 Like

First make sure you have up-to-date mirrors for both Arch and EnOS. You can refresh your mirrors from the Welcome app. Try updating your system again.

If the situation remains the same, do the following:

Remove yay first: sudo pacman -Rs yay

Next, update your system: sudo pacman -Syu

If you are on EnOS, install yay from its repo: sudo pacman -S yay

If not, install it manually from AUR again.

:smiley: great ! thanks a lot

1 Like

You are welcome! Glad to know that you got the issue resolved!

:enos: :wave:t5:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.