Deleted a linux partiton in my dual boot setup

Hello everyone, I have dual boot EOS and win11 on 2 different SSDs, but last night I messed up and I deleted a partition from the linux ssd. When I tried to boot it was stuck at some point and now I tried reinstalling endeavourOS but it feels like something is not right. I want to delete everything related to it and try again from scratch. Now I am in a live usb session so I can solve it, with your advice. The output for sudo parted -l is:

[liveuser@eos-2023.05.28 ~]$ sudo parted -l
Model:  USB  SanDisk 3.2Gen1 (scsi)
Disk /dev/sda: 15.4GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  15.4GB  15.4GB  primary  fat32        boot, lba

Model: Samsung SSD 970 EVO Plus 500GB (nvme)
Disk /dev/nvme0n1: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                  Flags
 1      2097kB  1051MB  1049MB  fat32                              boot, esp
 2      1051MB  500GB   499GB   ntfs         Basic data partition  msftdata

Model: SAMSUNG MZVL21T0HCLR-00BL2 (nvme)
Disk /dev/nvme1n1: 1024GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  274MB   273MB   fat32        EFI system partition          boot, esp
 2      274MB   290MB   16.8MB               Microsoft reserved partition  msftres
 3      290MB   1022GB  1022GB  ntfs         Basic data partition          msftdata
 4      1022GB  1024GB  2097MB  ntfs         Basic data partition          hidden, diag, no_automount

and for efibootmgr is:

BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 2001,0005,0004,0000,2002,2003
Boot0000* Windows Boot Manager	HD(1,GPT,85b23aee-5041-4801-b005-9bce1dc00278,0x1000,0x1f4000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* EFI USB Device (USB)	UsbWwid(781,5583,0,0501ed4df5dfe5d5d0144e5845fc85fe7b869afbe9999f0105fb7ffcbb388bf6bab9000000000000000000006527a9c1ff9b0510835581078c2cf41)/HD(1,MBR,0xbd3b1d,0x800,0x1ca3800)RC
Boot0002* EFI PXE 0 for IPv4 (6C-24-08-A3-12-4B) 	PciRoot(0x0)/Pci(0x2,0x3)/Pci(0x0,0x0)/MAC(6c2408a3124b,0)/IPv4(,0,0)RC
Boot0003* EFI PXE 0 for IPv6 (6C-24-08-A3-12-4B) 	PciRoot(0x0)/Pci(0x2,0x3)/Pci(0x0,0x0)/MAC(6c2408a3124b,0)/IPv6([::]:<->[::]:,0,0)RC
Boot0004* Windows Boot Manager	HD(1,GPT,a4ae3479-23b6-4c85-9ed4-9c9215776599,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000000000100000010000000040000007fff0400
Boot0005* Linux Boot Manager	HD(1,GPT,85b23aee-5041-4801-b005-9bce1dc00278,0x1000,0x1f4000)/File(\EFI\systemd\systemd-bootx64.efi)
Boot2001* EFI USB Device	RC
Boot2003* EFI Network	RC

You may not need to do anything. Seems there is an issue with the 6.4.1 Kernel. This is more than likely why it doesn’t “feel right”

Ok I see. From the output I posted, does it seem that there is anythin linux related in the 1TB ssd where windows is installed? How can I wipe everything (especially the boot for linux) and clean install it again?

If the kernel is infact the issue a reinstall is not going to help your only going to wind up with the same issue.

Before I messed up though there were no issues. So I would like to try and set it up again and see how it goes. So I would like to delete everything and then install it again. Because even if i want to install another distribution, I still have some old linux files/bootloader etc and I think they will mess it up again.

a simple format should remove all files from the drive.

as far as the boot files I am not the one to help with that. I don’t dual boot.

if you decide to do a reinstall you may want to choose ofline mode instead of online and go with the older kernel until they fix the latest one.

Explain, please. Maybe you were just tired :stuck_out_tongue_winking_eye: .

There is no visible empty space in the 1TB drive.

You can delete both partitions on the 500GB drive, and start EnOS installation, selecting that drive for target. Then, if anything doesn’t feel right, post a detailed description of your feelings :joy: .

Everything looks WinOS-related on that drive.

I didn’t explain thoroughly my feeilings (:joy:) because I thought that if I could delete everything, then it would work as before. The first time I installed endeavourOS it detected both screens (laptop + exterrnal monitor) and everything worked out of the box. Now the external monitor is not active, although it is detected. Also when I try to restart/reboot/sleep the laptop and I press the such option, it is very laggish. I mean the second time you select the restart (in the screen that also has a countdown for auto restart after 30 seconds). Generally it didn’t feel like the first time and many things were not as fluid as before.
Regarding the 500GB ssd, even when I deleted everything while I was on windows, the next time I rebooted there was the option to boot into linux. That’s why I am asking if there is anything in the 1TB ssd that has to do with the linux bootloader. I have a legion 5 pro with nvidia gpu (3070ti). Do I need to install anything before linux makes the external monitor working again?

UPDATE: I don’t know what happened but the last installation worked. It detected the monitor right away and everything feels good. No bugs, no issues with the speakers or anything. Thank you both for spending some time on this issue. Have a great day/night!


It sounds like you selected different boot menu options, when booting the Live Installer. There is one special for Nvidia-optimus HW and one for all the rest.
You may want to try both options and stay on the one that feels better :wink: .

As I said, it seems you converted the Linux partition to a WinOS type (NTFS). Not deleted.
The Linux boot option is initiated because the files that create it are still inside the FAT32 partition (the $ESP). There is no need to delete those, though. A new installation will take care of everything.
If you encounter problems, post for advice.

"You may not need to do anything. Seems there is an issue with the 6.4.1 Kernel. This is more than likely why it doesn’t “feel right "

Just curious, what is the issue 6.4.1 Kernel?

Edit: found this-