Delayed charging status on Lenovo Flex 5

I am using a Lenovo Flex 5 ARE05 (Ryzen 5 4500u), and when installing Endeavour from the latest iso as of May 2nd 2022, my charging status seemed to be delayed by 120 seconds, and it would be immediately updated when refreshing upower with the associated busctl command. Browsing forums led me to believe it was an issue with upower, but it turns out that for me, I just needed to install the package acpid. Just posting this in case anyone else has had a similar issue and hasn’t tried this yet.
[EDIT 5/3/22] : Actually, after fiddling around for a few hours, I realized that acpid wasn’t the reason for it: while I was trying to resolve it, I pasted the following command from the Arch Wiki:
echo 1 > /sys/bus/platform/drivers/ideapad_acpi/VPC2004:00/conservation_mode
This turned on the battery conservation mode, which actually fixed the charging status issue, but in exchange, stops the battery from charging beyond a certain threshold (somewhere around 55-60% if the Lenovo Vantage application on windows is to be believed). So this is technically resolved, but losing out on about 40% of my battery doesn’t seem worth it. If anyone knows how to file a bug or something for this, it’d be greatly appreciated if you could tell me how, as I’m pretty new to this.

1 Like

Welcome to EnOS’ forum @waffleboi9000!
And thanks for sharing your findings!
:enos_flag:

1 Like

Lenovo laptops can expose more information using the acpi_call driver module - might be worth trying if you haven’t already got it installed.

I actually do have acpi_call installed, as it was advised in the associated arch wiki, but it did not seem to make a difference. I have also tried using acpi_call-dkms with the zen kernel and this did not change anything either.

1 Like

From the lenovo site:

Try the charger on another device if possible to see if it can charge. If the charger is not working on another device, then there could be a hardware fault with the charger itself. If unable to test charging another device, try the steps below in an attempt to remedy the issue:

Step 1. Static Discharge on Laptop and AC adapter.

  • Remove all cables attached to the laptop (hdmi, external mouse/keyboard, etc)
  • Ensure device is switched OFF
  • Keep the AC adapter connected to the laptop, but disconnected from the wall socket Important
  • Hold down power button for 60 seconds
  • Re-attach all cables
  • Connect the AC Adapter, then let the device charge for about 2 minutes (if it does) then start up as usual.
  • Try it a couple of times (2-3)

Step 2. Checking The Advanced Power Options.

  • In the Search function type : Control Panel
  • From the View By: select Large/Small Icons. Then Select “Power Options”.
  • Click “Edit Power Plan” for the plan of your device.
  • Select “Change advanced power settings”
  • Find and expand “USB Settings”
  • Make sure the “USB selective suspend setting” is set to “disabled”

Step 3. BIOS Load Default Settings.

  • Select the Start Menu, then choose Settings > Update & Security > Recovery. Under Advanced startup, select Restart now. After your PC restarts to the Choose an option screen, select Troubleshoot > Advanced options > UEFI Firmware settings
    :or:
  • Press the power button to completely shut down the unit.
  • Press the F1 or F2 (FN+F1 or F2) repeatedly on startup to enter BIOS.
  • Navigate to the “Restart” tab
  • Press “Load Default Settings”
  • Save & Exit changes or F10.

Step 4. Check “Charge In Battery Mode”.

  • Re-enter the BIOS and navigate to the “Configuration” tab.

  • Make sure the “Charge in Battery Mode” is set to “Enabled”

  • Make sure the “Always on USB” is set to “Enabled”

Also check out the Lenovo Service Tips found Here

Edit: I realize some of this stuff also revolves around “Windows”!

2 Likes

Unfortunately, none of these steps seemed to resolve the issue.

Did you set the usb to always on? Where are you plugging in to charge? Is it usb C? Some laptops have two usb-c ports one is for external charging and the other is for charging the laptop.

Edit: Have you checked for a Bios update?

The USB is set to always on, the device is plugged directly into a wall outlet, it is a USB C charger, but there is only a single usb C port on the device. There is a barrel type charger, but the charger that came with the device was a USB C charger. The charging status works perfectly on windows, so I don’t think it would be a hardware issue. There are no BIOS updates available.

Did you set this up or just install it? There is a number of different settings regarding power management.

https://wiki.archlinux.org/title/Lenovo_IdeaPad_Flex_5_14alc05#Power_management

First, my device is the ARE05:
https://wiki.archlinux.org/title/Lenovo_IdeaPad_Flex_5_14ARE05
Second, I installed the acpid package, but did no additional setup with it. This did not actually resolve the issue, as it was just one of several fixes I attempted. I was able to reproduce the “fix” by enabling the battery conservation mode, and disabling it immediately brought back the delay in the charging status.

Not sure what your issue is then. If you can fix the issue but it gives another issue such as only charging to 60% that’s how it’s set up to work this way from what i have read. Maybe there is a way to change that if that’s your issue? I don’t have this problem on any of my laptops with EndeavourOS. I do have an ideapad and a thinkbook and an HP. The ideapad only has Windows on it so i don’t know if it has any issues like this. The others don’t.

Maybe this is not the case with you by accident?
https://forums.lenovo.com/t5/Lenovo-IdeaPad-1xx-3xx-5xx-7xx-Edge-LaVie-Z-Flex-Notebooks/Flex-5-ideapad-slow-charging-over-USB-C/m-p/5037736

As I have said, the device charges normally on windows (using the USB C), and does update the charging status immediately. My issue is not with the charging itself, just the icon in the corner not reporting that the charger has been unplugged until approximately 120 seconds have passed. It might be relevant to mention that it immediately recognizes the charger being plugged in, but is slow to recognize that the charger has been unplugged. This may or may not be related to another minor annoyance where plugging in the charger for the first time after booting will reduce the screen brightness to the minimum.