Deja Dup backup won't start!


I’ve been using deja dup for years to perform my backups as it fulfils my basic needs and is inbuilt with Gnome (I’m sure there are ‘better’ solutions)

I’ve just noticed its not been running for a while

When I click the backups icon nothing happens

Running deja-dup from the command line produces the following error:

deja-dup: symbol lookup error: deja-dup: undefined symbol: adw_view_stack_get_visible_child_name, version LIBADWAITA_1_0

Can anyone assist, I’ve tried googling the error etc to no avail

System is fully up to date

Many thanks


Can we see the output of pacman -Q | grep -E "deja|adwaita"


Thanks for quick response

adwaita-icon-theme 41.0-1
deja-dup 43.2-1
libadwaita-git 1:r1596.65ac525-1
ttf-dejavu 2.37+18+g9b5d1b2f-3

Is there a reason you are using libadwaita-git? I would try replacing that with the normal libadwaita, like this:

sudo pacman -Syu libadwaita

Thank you so much Dalto thats fixed it.

Sadly, the reason for libadwaita-git are lost in the mists of time…

I really appreciate the help

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.