Default autostartup are not working like .xprofile

I have been noticing that all my .xprofile .xsession .xinitrc, none of them are executed on startup. which has all my necessary programs which has to start on the boot. also i tried to use the crontab for executing my required startups when booted even that is not working. So could anyone please help me out of this

What DE/WM are you using? Most DE have autostart feature. On WM, they WM config can usually call external script to auto start apps.

i even tried them but they are also not working

What Desktop Environment or Window Manager are you using?

i am using kde and X11

1 Like

In KDE System Settings, under Startup and Shutdown, you should see Autostart option.
Have you tried that? For reference, this is how it should look

yes i have tried that even thats not working

Can you run xbindkeys via the terminal? Does it run or does it exit with error.
Also, if you’re aiming for setting up key board shortcuts, I believe you can set them up in KDE Settings itself.

Also, whats the output of

ps aux | grep xbindkeys

i have tried both the ways even then its not working

image

image

xbindkeys seems to be running.

Then, I suspect the issue isn’t with xbindkeys or KDE itself, but possibly the key presses aren’t being registered on system? I’m not of much help if that’s the case though.

the thing is once i run the xbindkeys on the terminal all the key binding are working fine

I’m out of ideas :sweat:

no problem, thanks for the help

1 Like

by the way do u know why none of the startup scripts are running ?
i mean .xprofile , .xsession , .xinitrc