Dconf, how to create and set a key properly?

I wanted to grab gnome 3.38 from it’s source code and try running it. I didn’t have any gnome packages before trying this, then I installed all the dependencies, and I did get mutter 7 (not 8, that only works with 40). Gnome shell crashes when I run it. I tracked the bug down to this, after which mutter mysteriously coredumps.

(mutter:2026): GLib-GIO-ERROR **: 23:01:41.234: Settings schema 'org.gnome.settings-daemon.plugins.xsettings' does not contain a key named 'hinting'

looking online it seems this was removed in mutter 8. no worries, I set it myself:

dconf write /org/gnome/settings-daemon/plugins/xsettings/hinting "'grayscale'"

still doesn’t work, even after a reboot.

I decided to then check dconf-editor. It shows the key set, but it puts it under “Keys not defined by a schema - no schema found”. I suspect that’s my issue. How do I resolve this properly? Really would like to try to clean up 3.38’s code base and fix some bugs; I absolutely loved that release

gnome-shell-oldstable package provides 3.38. when 41 is released it might update to 40, in that case I’ll lock it. 3.38 4 life!

nice to see you talking happily with yourself :wink:


1 Like

well, I am using the gnome 40 control center, but for the rest I’m using the 3.38 versions :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.