Davinci Resolve "Unable to initialize gpu" after Nvidia update

Hello EndeavourOS community!

For my editing needs, I use Davinci Resolve which happens to run well on my laptop once I installed the dedicated AUR package.
With the correct environment variables, It initialises correctly with the CUDA checked by default (I run a multi-GPU laptop).

However, since a while now, I discovered when updating that Nvidia updates broke the flow, introducing the topic title error and me being unable to select CUDA (my GPU is still found by Resolve, Nvtop and any other program that needs it, I am currently on Nvidia 550.78).


Informations :

  • I installed the nvidia drivers with the nvidia-inst script
  • Resolve is launched with the environment variables : “__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia”
  • I am running Linux LTS
  • More hardware info : https://0x0.st/XmC0.txt

First I tried to resolve the problem by :

  • Removing the environment variables
  • Reinstalling the AUR package
  • Reinstalling an old .run file version of Resolve 17
  • Booting with the Arch Kernel (Non-LTS)
  • Booting with the Zen kernel
  • Rolling back to the Nvidia 550.78 drivers with pacman -U (this one is :exploding_head:)
  • Installing the nvidia-all package on Github

But none resolved the issue.

I eventually gave up by loading a pre-upgrade snapshot and by excluding Nvidia packages during updates. I believe since Nvidia drivers are “blobs”, it should not be too dangerous to keep old driver vresions running? But I am not sure, hence why I wish to get out, but this Resolve issue is puzzling me.

Any guesses ?

I apologise if this conclusion is already understood, but I suspect it’s here your issue stems from. That seems to be echoed by Resolve’s error message.

Firstly, if you have an option in the BIOS for it, make the Nvidia the primary GPU.

Then perhaps you might get some direction from here on how to expressly use that GPU.

OK, I followed the guide linked in your post and changed /etc/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf and /usr/share/sddm/scripts/Xsetup according to the guide and now Resolve works on Nvidia with the updated drivers! Thanks a lot!

My only bummers being :

  • Now my Intel GPU became basically useless, not great for battery life :sweat_smile:
  • (Rant) Davinci Resolve seems to be really crap when it comes to GPU detection, especially on Linux. I still can’t get behind the fact that updating my Nvidia drivers seemingly “broke” Resolve’s GPU detection with no way to fix it, not even by restoring the old cached drivers with pacman -U.(Rant ended)

Oh well, I’ll maybe setup a .desktop script that switches between.

1 Like

I use it on a single GPU desktop system, so I can’t speak from experience. However, I suspect the issues is particular to laptops, as their iGPU and discreet GPU are closely integrated (hybrid).

I wonder if it makes a case for the simplicity of an AMD/Ryzen APU based laptop.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.