Datatraveler Vault usb drive not automatically mounted

When I plug in my Kingston datatraveler vault usb drive i’m not able to mount it. It is recognized. With dmesg i can see that its connecting. How can I mount this flash drive?

[ +4,287444] usb 1-2: new high-speed USB device number 6 using xhci_hcd
[ +0,145374] usb 1-2: New USB device found, idVendor=0951, idProduct=160d, bcdDevice= 1.10
[ +0,000013] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ +0,000004] usb 1-2: Product: DTVault Privacy
[ +0,000003] usb 1-2: Manufacturer: Kingston
[ +0,000003] usb 1-2: SerialNumber: 001E0BB995CCBE2120000EAD
[ +0,000614] usb-storage 1-2:1.0: USB Mass Storage device detected
[ +0,000294] scsi host0: usb-storage 1-2:1.0
[apr15 16:51] scsi 0:0:0:0: Direct-Access Kingston DTVault Privacy PMAP PQ: 0 ANSI: 0 CCS
[ +0,000474] scsi 0:0:0:1: CD-ROM Kingston DTVault Privacy PMAP PQ: 0 ANSI: 0 CCS
[ +0,000823] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ +1,177855] sr 0:0:0:1: [sr0] scsi3-mmc drive: 0x/0x writer tray
[ +0,032814] sr 0:0:0:1: Attached scsi CD-ROM sr0
[ +0,000232] sr 0:0:0:1: Attached scsi generic sg1 type 5
[ +0,000113] sd 0:0:0:0: [sda] Attached SCSI removable disk

Is it encrypted? Does that drive support Linux for decrypting?

Part of it is. There is software on the non encrypted part of the drive to get access to the encrypted partition. It worked before. After reinstall of endeavour it doesn’t work anymore.

OK, so the unencrypted partition is failing to mount?

Do you get an error if you try to mount it from the command line?

It does’t see the partition at all. No error message.

What does lsblk show?

Nothing of the flash drive.

It did show the partition of the flash drive but did not mount him, i had to do this by hand. I changed the removable devices setup to auto mount removable media devices, but it won’t mount automatically.

[stephan@stephan-hpelitebook ~]$ lsblk
NAME        MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0         7:0    0 162,7M  1 loop /var/lib/snapd/snap/brave/108
loop1         7:1    0  55,4M  1 loop /var/lib/snapd/snap/core18/1997
loop2         7:2    0  64,8M  1 loop /var/lib/snapd/snap/gtk-common-themes/
loop3         7:3    0  32,3M  1 loop /var/lib/snapd/snap/snapd/11588
sr1          11:1    1    16M  0 rom
nvme0n1     259:0    0 476,9G  0 disk 
├─nvme0n1p1 259:1    0   300M  0 part /boot/efi
└─nvme0n1p2 259:2    0 476,6G  0 part /

How can I make this flash drive mount automatically?

Can it be because the Type is a “rom” instead of “disk” ?

Perhaps. I am not sure why it isn’t being auto-mounted.

As a workaround, you could add a systemd automount for it in /etc/fstab. Then it would try to mount it on access.

It is strange, on all other distributions I never had an issue with it.

Are you using the same DE on EndeavourOS that you did on other distributions?

Alternatively, you could investigate the related udev rules but that seems more complicated than just setting up an automount for it.

1 Like

On Mint/Elementary OS and Garuda (KDE) it works fine. The last time i used Endeavour os i also had no issues with the flash drive. But i don’t use the drive a lot, so it isn’t an issue to mount it by hand. And maybe in a future update this problem will be solved.

1 Like