Creation of /etc/X11/xorg.conf file could break your system

I don’t know how much it is a bug or just an incorrect stuff, but anyway, here’s how I had broken and fixed my system.

I’ve been looking for a way to fix my problem with Telegram Desktop, everywhere mouse scroll was working fine, but out of sudden it’s stoped working specifically in this app.
Also I tried to found a solution how to implement on Linux a scroll on the mouse wheel, and found here solution for kubuntu, that I thought should be working and on my EOS with KDE Plasma.

It’s been said to edit a file at this location - /etc/X11/xorg.conf.
But I had no such file at this direction, so i tried to create it with this content -

Section «InputClass»

Option «VertScrollDelta» “-111”
Option «HorizScrollDelta» “-111”


But after reboot my system started to stuck on mounting of the partitions from my second drive.
From grub - e - “linux” line + 3 - tty, I entirely removed from /etc/fstab everything besides my OS partition.
But it didn’t helped and system started to stuck on boot at this points -
[OK] reached target graphical interface
[OK] started Hostname Service

I looked at logs and found the error - Failed to read display number from pipe.
But drivers and everything else related to graphics was fine, so I stopped to think that perhaps system was broken by the updated and decided to do what I’ve should done first, removed my last action in system - sudo rm -f /etc/X11/xorg.conf

And everything started to work…

Moral - 1) undo your last action first when you encountered a problem 2) check first system changes in the VM. 3) Even the things that you think are harmless can broke your entire system in a unexpected ways.

Without knowing what else was wrong in the file, that’s not a valid quotation mark.

1 Like

A post was split to a new topic: Creation of /etc/X11/xorg.conf file may break your system

that no right … it be in /etc/X11/xorg.conf.d

В десктопной версии Telegram (версии 1.1.23) не работала прокрутка колесом мыши. Ни в одном из трёх фреймов, ни в настройках. Решение нашел на Чтобы заработало, нужно внести следующее изменение в эти два файла:

/etc/X11/xorg.conf is valid as a single configuration file; /etc/X11/xorg.conf.d is for drop-in files.

1 Like

yes . manjaro post point to /etc/X11/xorg,conf.d

that what i point out

Op post

It’s been said to edit a file at this location - /etc/X11/xorg.conf.

manjaro post
point /etc/X11/xorg.conf.d

that what i try explain


Look at the MihailGutorov answer.

Такая же проблема возникла на Kubuntu. Как ни странно, рецепт помог. Только добавлял эти строчки в файл /etc/X11/xorg.conf, так как вышеперечисленных у меня просто нет, в секцию InputDevice (которая для мыши).