Crash update, and laptop don't work

Hello! That moment has come. When I try the update system, my laptop is power off. Right now, system don’t want up… I have snapshot in timeshift, but maybe you know another way to restore system? would very much like to avoid reinstalling such a long-running system.

Depending on the boot mode of your installed system (UEFI VS. Legacy/MBR), choose the appropriate method from the links below and arch-chroot into your system:

Once chrooted into the system:

pacman -Syu

to run the updates. When finished type exit to quit chroot and reboot.

If you get any error messages at any step, please post them back here.

If anything is unclear, post about it.


At the moment I can’t run update: [root@EndeavourOS /]# sudo pacman -Syu :: Synchronizing package databases... error: failed to synchronize all databases (unable to lock database)
Perhaps I need to delete the pacman file that holds the open database from a failed update?

1 Like


rm /var/lib/pacman/db.lck
1 Like

The update was very short, and after restarting, the system communicated that vmlinuz was missing. Indeed, the /mnt/boot/efi folder was empty. I installed the LTS kernel and everything works beautifully now! Thank you very much for your help in saving such a long running system! I must add that this is the only system that has worked so long with me without failure. What happened was my oversight, because the battery on the inverter, was already too weak and discharged during the update. Thank you!

1 Like

Oftentimes this could be solved by rebuilding the initrds in the chroot by running:

mkinitcpio -P

for all the installed kernels.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.