Crash on live usb before install

Hi there,
I am at a loss and wondering if anyone out there could help shed some light.
I have tried Ubuntu, Majaro, GUIX and now Endeavour distros. All seem to crash at some point or another.
GUIX is the only one I got to get through the installer but it crashed seconds after actually booting

My system:
republic of gamers hero alpha V|||
NVIDIA GeForce RTX 2070 Super
I7 6700k 4GHz
16gig DDR corsair vengeance RAM

I can run Windows 10 and GhostDSD on this system with no issues at all which makes me think that my hardware is OK and this is something very specific with Linux.

Things I have tried:
I tried bot NVIDA and normal boot options on your like disk.
In the past I have tried setting boot options nomodeset, nomodeset-nvidia and also apci off

I have tried booting without the GPU attached.
I done a memory test when I first saw this.
I changed the ram as one stick was failing so there brand now RAM (I replaced both at the same time)
BIOS is up to date.
I cleaned the entire PC and repasted the CPU.

I am pretty much out of ideas and have no idea how to diagnose the issue as the system can’t stand up long enough to even tail /var/log/messages

Any ideas what I have missed?
What can I try?
What can I do to try and figure out what is causing this crash?
Thank you for taking the time to read this.
If I think of anything else I will try and add it.

Hi so to add some additional information
The motherboard is a Republic of gamers Maximus vIII hero alpha chipset z1701

I spoke to some people on the Telegram group. I am going to try using the vanilla Arch ISO
to see if that can get any logs or info in the meantime.

Hello @ArchaicLord
Are you using the latest ISO? How did you create the live USB? Make sure that secure boot and fast boot are off in UEFI Bios. When you boot from the current ISO make sure you are booting from Nvidia and do not update the welcome app when it loads. Start the installer and do the online install.

Hi thanks @ricklinux , fast boot is off and secure boot is disabled where OS is set to other

I booted into the Nvidia option.

I tried 2x this morning and it crashed at different times.

I was able to get a couole of photos

1 Like

Well the photos look great but it doesn’t really help I’m afraid. Can you tell me how you created the live USB? It 's possible it could be a problem with the usb stick, the downloaded ISO or the creation of the ISO. When you say it crashes what exactly happens?

I think if it was me i would experiment & download another current ISO and create a new live usb. The installer is working so it’s possible it could be a bad download or creation of the usb unless you have an issue with your hardware? The latest Bios version is 3801 dated 2108/04/27. What version is on your board? No memory issues? You say every distro you tried does this so i would be running a solid memory test and let it run for a longer stress test.

Surely a very very outdated one! :wink:

That’s what’s on their site as it is an older board and after a few years they don’t continue to provide more updates. It is what it is but, some people never update their Bios and a new board could have many updates. My new boards currently have had more than 13 since the original. They all are updates for supporting newer processors and performance improvements. It’s always worth checking in case they never updated it. It could be the original version at the time it was manufactured.

1 Like

Yeah, I got it!
But I alluded to

2108/04/27

:blush:

1 Like

Bios is up to date at 3801.
And iso I am currently using Blancher to make the USB.

I have used Rufus in the past but that has caused problems.

At the start of this journey I did find that one of the RAM sticks was faulty so I replaced them both with new from manufacture. I re done the mem test they are fine. The new ones are a couple of months old now. If they have failed already I would pretty upset.

If so had a memory issue like that I would see this issue on Windows. Especially while gaming.

Pretty much the only thing I can’t eliminate is the motherboard. And that would require a full rebuild most likely.

But as I said how is it windows and frebsd seem to run on this machine no.I used the same Blancher program to install and run GhostBSD.
Yet using it for Fedora, Ubuntu, Vanilla Arch, Manjaro Endeavour OS and GUIX every one of these have had this issue.

If you are referring to the installer hanging at refreshing the keys at 8% be patient. That part can take a while. A full install can take up to 30 mins.

No It just stops dead in its track the whole system.

So even if I didn’t start the installer and just played with say Firefox on the live iso it would glitch out and I wouldn’t be able to browse any more I would have to reboot the live iso to get it working.

At the point it stops working I cannot move the windows around or alt tab between them or read the debug window.

I cant’ do anything and I think I could leave it for 2 weeks and it wouldn’t progress.
It crashed at 1% and 8%. It’s really random it can crash in 5 secs it could crash in 3mins
Never seen it last longer than 5mins to be honest.

somebody with the same hardware had similar issues failing to install several distros

https://rog.asus.com/forum/showthread.php?84971-Linux-on-Z170-ROG

apparently fixed it by booting with a USB 2

seems odd that would work but also seems odd that you are failing with every distro you have tried

worth a shot while waiting for someone smarter than me to come up with a fix

That is a great suggestion. I have ran into this in the past with Ubuntu.

I only ever brought usb 2.0 ever since.

And I have been watery not to use a usb 3.0 port on the system.
What I did try was using one of the ports on the back instead of the front.

It got a little further I could see the terminal East starting to download packages like open SSL but again it just stopped dead
:frowning:

I have a thought that maybe I could try burning to a DVD instead. I do t have any disks lying around but I don’t know I feel like I still gonna see the issue.

They mentioned in that post fedora 23 maybe I could try that and see if that works but I feel that’s a very bad idea.

I am not familiar with blancher? Do you mean balena etcher? I use popsicle now. As you are gaming also wondered if you have some funky settings in your Bios? Maybe reset to default, check that secure boot and fast boot are off after restting it and save the settings. Then try installing again.

1 Like

Yes balena etcher (Dyslexia)

In bios only things I would have done is a 10% stock overclock, enabled virtualization, set boot device
Removed secure boot.

Pretty sure I reset bios when I first done this, and also tried disabling the hyperthreading or multithreading what ever that was.

I can certainly try and do a bios reset again as I have messed with it since then. Will let you know how it goes

Hey,
Resetting the bios only changed turning off virtualization setting and again it crashed while I was trying to select the disk partitioning.
So again it’s crashed at a different point in time.
:frowning:

Are you booting it on Nvidia when starting the live usb? There are two entries. Have you tried it on the other boot to see? It may or may not boot on it but could see.

Yep, I done both before, just tried it again and same result on the other install option (cd)

Could you boot on the live usb and install inxi.
sudo pacman -S inxi

Then post the link from this command

inxi -Fxxxz --no-host | eos-sendlog

Also

sudo fdisk -l

Hi @ricklinux,
I was just about able to sign in and dump the output here before it crashed on me.
inxi won’t install there is a 404 error.

Fdisk -l looks like the main disk I am trying to install has partionied according to the details I set on the installation and what part of the install it was able to get done.
Does this help?


 Retrieving packages...
error: failed retrieving file 'inxi-3.3.00.1-1-any.pkg.tar.zst' from mirror.alpix.eu : The requested URL returned error: 404
error: failed retrieving file 'inxi-3.3.00.1-1-any.pkg.tar.zst' from ftp.acc.umu.se : The requested URL returned error: 404
error: failed retrieving file 'inxi-3.3.00.1-1-any.pkg.tar.zst' from mirror.linux.pizza : The requested URL returned error: 404
error: failed retrieving file 'inxi-3.3.00.1-1-any.pkg.tar.zst' from mirrors.tuna.tsinghua.edu.cn : The requested URL returned error: 404
error: failed retrieving file 'inxi-3.3.00.1-1-any.pkg.tar.zst' from mirror.ghead.work : The requested URL returned error: 404
error: failed retrieving file 'inxi-3.3.00.1-1-any.pkg.tar.zst' from raw.githubusercontent.com : The requested URL returned error: 404
warning: failed to retrieve some files
error: failed to commit transaction (failed to retrieve some files)
Errors occurred, no packages were upgraded.
[liveuser@eos-2021.02.03 ~]$ sudo fdisk -l
Disk /dev/sda: 465.76 GiB, 500107862016 bytes, 976773168 sectors
Disk model: Samsung SSD 860 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 3530FD0A-56A7-2D4D-8791-8A63C1C19688

Device         Start       End   Sectors   Size Type
/dev/sda1       4096    618495    614400   300M EFI System
/dev/sda2     618496 940851364 940232869 448.3G Linux filesystem
/dev/sda3  940851365 976768064  35916700  17.1G Linux swap


Disk /dev/sdb: 14.32 GiB, 15376318464 bytes, 30031872 sectors
Disk model: Cruzer Dial     
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x5ee48d36

Device     Boot Start     End Sectors  Size Id Type
/dev/sdb1  *        0 3993791 3993792  1.9G  0 Empty
/dev/sdb2         180  131251  131072   64M ef EFI (FAT-12/16/32)









Disk /dev/loop0: 1.78 GiB, 1911021568 bytes, 3732464 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
[liveuser@eos-2021.02.03 ~]$